aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-05 21:30:34 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-05 21:30:34 +0000
commitb50c4a004fcfcbcd06e3a4cadd315b15fa469127 (patch)
tree09ba962029988558164753b32cebdb7448295f07
parentf0dcdd522f5810814e07bb02b63e106dee735aeb (diff)
downloadports-b50c4a004fcfcbcd06e3a4cadd315b15fa469127.tar.gz
ports-b50c4a004fcfcbcd06e3a4cadd315b15fa469127.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libphish/Makefile34
-rw-r--r--devel/libphish/distinfo3
-rw-r--r--devel/libphish/files/patch-src-phish_opdb_server.c10
-rw-r--r--devel/libphish/files/patch-src-phish_util_net.c20
-rw-r--r--devel/libphish/pkg-descr15
-rw-r--r--devel/libphish/pkg-plist37
7 files changed, 120 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9b726ae2bb5a..d2cf373a1079 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -527,6 +527,7 @@
SUBDIR += libpci
SUBDIR += libpdel
SUBDIR += libpeak
+ SUBDIR += libphish
SUBDIR += libpperl
SUBDIR += libredblack
SUBDIR += libshbuf
diff --git a/devel/libphish/Makefile b/devel/libphish/Makefile
new file mode 100644
index 000000000000..565861d0c90a
--- /dev/null
+++ b/devel/libphish/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libphish
+# Date created: 17 Apr 2006
+# Whom: Rashid N. Achilov <shelton@granch.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libphish
+PORTVERSION= 0.1.0
+CATEGORIES= devel
+MASTER_SITES= http://download.berlios.de/opdb/ \
+ http://download2.berlios.de/opdb/ \
+
+MAINTAINER= shelton@granch.ru
+COMMENT= A cross-platform library to interact with the Open Phishing Database
+
+BUILD_DEPENDS= xmlwf:${PORTSDIR}/textproc/expat2
+
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+USE_GCC= 3.2+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS= -I${LOCALBASE}/include -DFreeBSD
+LDFLAGS= -L${LOCALBASE}/lib
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} `${LS}` ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libphish/distinfo b/devel/libphish/distinfo
new file mode 100644
index 000000000000..1821d38c806d
--- /dev/null
+++ b/devel/libphish/distinfo
@@ -0,0 +1,3 @@
+MD5 (libphish-0.1.0.tar.bz2) = d6d81794e4147297917065d4465b233f
+SHA256 (libphish-0.1.0.tar.bz2) = a369769c73fde9bd908159f9b638580a50ef7c30850b4de9d476a3c4d2e76811
+SIZE (libphish-0.1.0.tar.bz2) = 246336
diff --git a/devel/libphish/files/patch-src-phish_opdb_server.c b/devel/libphish/files/patch-src-phish_opdb_server.c
new file mode 100644
index 000000000000..30053756e20e
--- /dev/null
+++ b/devel/libphish/files/patch-src-phish_opdb_server.c
@@ -0,0 +1,10 @@
+--- src/phish_opdb_server.c.orig Sun Mar 19 11:40:55 2006
++++ src/phish_opdb_server.c Mon Jun 5 13:33:51 2006
+@@ -21,6 +21,7 @@
+ #define close closesocket
+ #include <winsock2.h>
+ #else
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <unistd.h>
+ #endif
diff --git a/devel/libphish/files/patch-src-phish_util_net.c b/devel/libphish/files/patch-src-phish_util_net.c
new file mode 100644
index 000000000000..ba3c6ccbfd7d
--- /dev/null
+++ b/devel/libphish/files/patch-src-phish_util_net.c
@@ -0,0 +1,20 @@
+--- src/phish_util_net.c.orig Mon Mar 20 09:54:25 2006
++++ src/phish_util_net.c Mon Jun 5 13:40:14 2006
+@@ -30,6 +30,8 @@
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <netdb.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #endif
+
+ #include "phish.h"
+@@ -72,7 +74,7 @@
+ h->ent = NULL;
+ h->buf = NULL;
+
+-#ifdef WIN32
++#if defined(WIN32) || defined(FreeBSD)
+
+ h->ent = gethostbyname(name);
+
diff --git a/devel/libphish/pkg-descr b/devel/libphish/pkg-descr
new file mode 100644
index 000000000000..a546de7bbd4a
--- /dev/null
+++ b/devel/libphish/pkg-descr
@@ -0,0 +1,15 @@
+The Open Phishing Database project is an effort to create and
+maintain and open database of phishing sites, in addition to
+providing browser extensions which utilise this database in
+order to provide users with a safer browsing experience.
+
+libphish is a cross-platform library to interact with the Open
+Phishing Database, in order to provide a consistent API which
+browsers and other programs can use to verify the safety and
+risk level of URLs.
+
+Another part of OPDB is a Konqueror Anti-Phishing toolbar
+(see www/karpion port) and FirePhish - a Firefox Anti-Phishing
+toolbar.
+
+WWW: http://opdb.berlios.de/
diff --git a/devel/libphish/pkg-plist b/devel/libphish/pkg-plist
new file mode 100644
index 000000000000..42f44e4c8599
--- /dev/null
+++ b/devel/libphish/pkg-plist
@@ -0,0 +1,37 @@
+lib/libphish.so.1
+lib/libphish.a
+lib/libphish.la
+include/phish.h
+bin/libphish-config
+@unexec rm -f %D/lib/libphish.so
+%%PORTDOCS%%%%DOCSDIR%%/Doxyfile
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/files.html
+%%PORTDOCS%%%%DOCSDIR%%/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/globals.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_enum.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_eval.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_func.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_type.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/main.html
+%%PORTDOCS%%%%DOCSDIR%%/phish_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/phish_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/structphish__url__data__t.html
+%%PORTDOCS%%%%DOCSDIR%%/tree.html
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2blank.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2doc.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2folderclosed.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2folderopen.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2vertline.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2lastnode.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2link.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2mlastnode.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2mnode.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2node.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2plastnode.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2pnode.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%