aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-04-13 15:44:09 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-04-13 15:44:09 +0000
commitf13206cb35ec7208c057fffd655d36bf03e4b64d (patch)
treeb2c9b52b30f2d79cca0c67500664b28fea0f2907
parentd532038c00be794b6eee2e8069dbaaf336748033 (diff)
downloadports-f13206cb35ec7208c057fffd655d36bf03e4b64d.tar.gz
ports-f13206cb35ec7208c057fffd655d36bf03e4b64d.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-flakes/Makefile22
-rw-r--r--devel/py-flakes/distinfo3
-rw-r--r--devel/py-flakes/pkg-descr7
-rw-r--r--devel/py-flakes/pkg-plist8
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 73b4fcae435a..36146c84aa44 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1437,6 +1437,7 @@
SUBDIR += py-epsilon
SUBDIR += py-fam
SUBDIR += py-fileutils
+ SUBDIR += py-flakes
SUBDIR += py-fortran
SUBDIR += py-freebsd
SUBDIR += py-game
diff --git a/devel/py-flakes/Makefile b/devel/py-flakes/Makefile
new file mode 100644
index 000000000000..ae0fe66e1a8a
--- /dev/null
+++ b/devel/py-flakes/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-flakes
+# Date created: 13 Apr 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flakes
+PORTVERSION= 0.2.1
+CATEGORIES= devel python
+MASTER_SITES= http://divmod.org/static/projects/pyflakes/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyflakes-${PORTVERSION}
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= Pyflakes is a program that analyzes Pythom programs for errors
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+NO_BUILD= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-flakes/distinfo b/devel/py-flakes/distinfo
new file mode 100644
index 000000000000..52df9075b58f
--- /dev/null
+++ b/devel/py-flakes/distinfo
@@ -0,0 +1,3 @@
+MD5 (pyflakes-0.2.1.tar.gz) = e65d9245d706350b3db811280d897f30
+SHA256 (pyflakes-0.2.1.tar.gz) = 3eecd66deecc2de5c31bb91a4b4479232087e80da94e3086e2a686879374cde9
+SIZE (pyflakes-0.2.1.tar.gz) = 6140
diff --git a/devel/py-flakes/pkg-descr b/devel/py-flakes/pkg-descr
new file mode 100644
index 000000000000..0d95f1e3b0bf
--- /dev/null
+++ b/devel/py-flakes/pkg-descr
@@ -0,0 +1,7 @@
+Pyflakes is a simple program which checks Python source files for errors. It is
+similar to PyChecker in scope, but differs in that it does not execute the
+modules to check them. This is both safer and faster, although it does not
+perform as many checks. Unlike PyLint, Pyflakes checks only for logical errors
+in programs; it does not perform any checks on style.
+
+WWW: http://www.divmod.org/projects/pyflakes
diff --git a/devel/py-flakes/pkg-plist b/devel/py-flakes/pkg-plist
new file mode 100644
index 000000000000..d05e284e9382
--- /dev/null
+++ b/devel/py-flakes/pkg-plist
@@ -0,0 +1,8 @@
+bin/pyflakes
+%%PYTHON_SITELIBDIR%%/pyflakes/__init__.py
+%%PYTHON_SITELIBDIR%%/pyflakes/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pyflakes/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pyflakes/messages.py
+%%PYTHON_SITELIBDIR%%/pyflakes/messages.pyc
+%%PYTHON_SITELIBDIR%%/pyflakes/messages.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/pyflakes