aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2011-02-07 16:53:04 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2011-02-07 16:53:04 +0000
commit5f3c1885eb64684ba345af1dbb234839c2c006ca (patch)
tree520099ef4aed785910e5052e86cbf0fbc1bac82e
parent6dff9d42fbacff6acd6b1fca81dc4108917c60df (diff)
downloadports-5f3c1885eb64684ba345af1dbb234839c2c006ca.tar.gz
ports-5f3c1885eb64684ba345af1dbb234839c2c006ca.zip
- Update to 0.3.6.
- Fix rc scripts. [1] Submitted by: az [1] Reviewed by: dougb [1] Feature safe: yes
Notes
Notes: svn path=/head/; revision=268761
-rw-r--r--mail/rspamd/Makefile9
-rw-r--r--mail/rspamd/distinfo4
-rw-r--r--mail/rspamd/files/rspamd.in (renamed from mail/rspamd/files/rspamd.sh.in)29
-rw-r--r--mail/rspamd/files/rspamd_redirector.in (renamed from mail/rspamd/files/redirector.sh.in)10
-rw-r--r--mail/rspamd/pkg-plist3
5 files changed, 31 insertions, 24 deletions
diff --git a/mail/rspamd/Makefile b/mail/rspamd/Makefile
index 58f5a588c7ac..49849fe82bc7 100644
--- a/mail/rspamd/Makefile
+++ b/mail/rspamd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rspamd
-PORTVERSION= 0.3.5
+PORTVERSION= 0.3.6
CATEGORIES= mail
MASTER_SITES= http://highsecure.ru/
@@ -21,7 +21,7 @@ OPTIONS= RSPAMD_GPERF "Enable google perf-tools profiling" off \
RSPAMD_JUDY "Enable Judy arrays usage for performance" off \
RSPAMD_REDIRECTOR "Install HTTP redirector" off
-USE_RC_SUBR= rspamd.sh
+USE_RC_SUBR= rspamd
LICENSE= BSD
@@ -36,6 +36,9 @@ USE_LDCONFIG= yes
USE_GNOME= glib20
USE_LUA= 5.1-
+MAN8= rspamd.8
+MAN1= rspamc.1
+
.include <bsd.port.pre.mk>
.if defined(WITH_RSPAMD_GPERF)
@@ -51,7 +54,7 @@ USE_LUA= 5.1-
USE_PERL= 5.8+
CMAKE_ARGS+= -DENABLE_REDIRECTOR=ON
PLIST_SUB+= REDIRECTOR=""
- USE_RC_SUBR+= redirector.sh
+ USE_RC_SUBR+= rspamd_redirector
RUN_DEPENDS+= \
p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String \
diff --git a/mail/rspamd/distinfo b/mail/rspamd/distinfo
index f38a0a2875ce..d9a4e5a2e4f0 100644
--- a/mail/rspamd/distinfo
+++ b/mail/rspamd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rspamd-0.3.5.tar.gz) = 23e5b834cf1846efec1a7913563a65f98be0065e621b601fb7150ad275c4af96
-SIZE (rspamd-0.3.5.tar.gz) = 707938
+SHA256 (rspamd-0.3.6.tar.gz) = 4c8436b1f6aa30bd8353bc487dd65e39254783eb20e3e2038fb2508b93d15f4e
+SIZE (rspamd-0.3.6.tar.gz) = 714557
diff --git a/mail/rspamd/files/rspamd.sh.in b/mail/rspamd/files/rspamd.in
index 2c9f20c3527b..e41c3498a46b 100644
--- a/mail/rspamd/files/rspamd.sh.in
+++ b/mail/rspamd/files/rspamd.in
@@ -5,22 +5,29 @@
# PROVIDE: rspamd
# REQUIRE: LOGIN
# KEYWORD: shutdown
-
#
-# Add the following line to /etc/rc.conf to enable countd:
-# rspamd (bool): Set to "NO" by default.
-# Set it to "YES" to enable rspamd.
+# Add the following line to /etc/rc.conf to enable rspamd:
+#
+# rspamd_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable rspamd.
+#
+# rspamd_user (str): Default to "nobody".
+#
+# rspamd_group (str): Default to "nobody".
. /etc/rc.subr
-name="rspamd"
+name=rspamd
rcvar=`set_rcvar`
-procname="%%PREFIX%%/bin/rspamd"
+command=%%PREFIX%%/bin/rspamd
restart_precmd="rspamd_checkconfig"
reload_precmd="rspamd_checkconfig"
configtest_cmd="rspamd_checkconfig"
reopenlog_cmd="reopenlog_cmd"
+pidfile="$rspamd_pidfile"
+required_files=%%PREFIX%%/etc/rspamd.xml
+
load_rc_config $name
: ${rspamd_enable="NO"}
@@ -28,14 +35,12 @@ load_rc_config $name
: ${rspamd_user="nobody"}
: ${rspamd_group="nobody"}
-pidfile="$rspamd_pidfile"
-
stop_postcmd="rm -f $rspamd_pidfile"
rspamd_checkconfig()
{
- echo "Performing sanity check on rspamd configuration:"
- eval ${command} -t
+ echo "Performing sanity check on rspamd configuration:"
+ eval ${command} -t
}
reopenlog_cmd()
@@ -43,10 +48,10 @@ reopenlog_cmd()
pkill -USR1 -F $rspamd_pidfile
}
-extra_commands="reload configtest reopenlog"
sig_reload="HUP"
-command="$procname"
command_args="-u ${rspamd_user} -g ${rspamd_group} -c /usr/local/etc/rspamd.xml"
+extra_commands="reload configtest reopenlog"
run_rc_command "$1"
+
diff --git a/mail/rspamd/files/redirector.sh.in b/mail/rspamd/files/rspamd_redirector.in
index 8c24e624d5a4..fa750b0ad590 100644
--- a/mail/rspamd/files/redirector.sh.in
+++ b/mail/rspamd/files/rspamd_redirector.in
@@ -7,15 +7,16 @@
# KEYWORD: shutdown
#
-# Add the following line to /etc/rc.conf to enable countd:
-# rspamd-redirector (bool): Set to "NO" by default.
-# Set it to "YES" to enable redirector.
+# Add the following line to /etc/rc.conf to enable rspamd_redirector:
+#
+# rspamd_redirector_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable redirector.
. /etc/rc.subr
name="rspamd_redirector"
rcvar=`set_rcvar`
-procname="%%PREFIX%%/bin/rspamd-redirector"
+command="%%PREFIX%%/bin/rspamd-redirector"
load_rc_config $name
@@ -27,7 +28,6 @@ stop_postcmd="rm -f $rspamd_redirector_pidfile"
extra_commands="reload"
sig_reload="USR1"
-command="$procname"
command_interpreter="/usr/bin/perl"
run_rc_command "$1"
diff --git a/mail/rspamd/pkg-plist b/mail/rspamd/pkg-plist
index aadf233d75b9..98b62199e4b9 100644
--- a/mail/rspamd/pkg-plist
+++ b/mail/rspamd/pkg-plist
@@ -14,13 +14,12 @@ etc/rspamd.xml.sample
%%ETCDIR%%/plugins/lua/whitelist.lua
%%ETCDIR%%/plugins/lua/phishing.lua
%%ETCDIR%%/plugins/lua/trie.lua
+%%ETCDIR%%/plugins/lua/emails.lua
%%ETCDIR%%/lua/regexp/drugs.lua
%%ETCDIR%%/lua/regexp/fraud.lua
%%ETCDIR%%/lua/regexp/headers.lua
%%ETCDIR%%/lua/regexp/lotto.lua
%%ETCDIR%%/lua/rspamd.lua
-lib/librspamd_ipmark.so
-lib/librspamd_regmark.so
lib/librspamdclient.so.%%RSPAMDVERSION%%
lib/librspamdclient.so
lib/librspamdclient_static.a