aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2009-09-26 22:08:43 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2009-09-26 22:08:43 +0000
commitf295d8d3bcea0592e3bae9e7b8c20b197f5fdb42 (patch)
tree11d9aae850a6ff6da5469812086afab3b08acc2f
parent093bbce65c500454a6e8154c9c7da8c576a5acd1 (diff)
downloadports-f295d8d3bcea0592e3bae9e7b8c20b197f5fdb42.tar.gz
ports-f295d8d3bcea0592e3bae9e7b8c20b197f5fdb42.zip
For GCC 4.5 libgcj has been broken up such compilation no longer requires
more than half a GB of memory. Accordingly, we can now remove the build- time test for that from pre-everything. Feature safe: yes
Notes
Notes: svn path=/head/; revision=242154
-rw-r--r--lang/gcc/Makefile9
-rw-r--r--lang/gcc45/Makefile9
-rw-r--r--lang/gcc46/Makefile9
-rw-r--r--lang/gcc47/Makefile9
-rw-r--r--lang/gcc48/Makefile9
5 files changed, 0 insertions, 45 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 658a1b116cc7..c659957b834b 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -137,15 +137,6 @@ PLIST_SUB+= JAVA="@comment "
pre-everything::
@${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
-.if ! defined(WITHOUT_JAVA)
- @DSIZ=700000; DSIZBYTE=734003200; \
- if [ `ulimit -d` -lt $$DSIZ ]; then \
- echo "You need to increase the datasize limit to at least $$DSIZ \
- (and set kern.maxdsiz=\"$$DSIZBYTE\" in /boot/loader.conf) to \
- build with Java support." | ${FMT} -s; \
- exit 1; \
- fi
-.endif
pre-extract:
@# Building libgcj with lang/gcc295 installed is causing a failure
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 658a1b116cc7..c659957b834b 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -137,15 +137,6 @@ PLIST_SUB+= JAVA="@comment "
pre-everything::
@${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
-.if ! defined(WITHOUT_JAVA)
- @DSIZ=700000; DSIZBYTE=734003200; \
- if [ `ulimit -d` -lt $$DSIZ ]; then \
- echo "You need to increase the datasize limit to at least $$DSIZ \
- (and set kern.maxdsiz=\"$$DSIZBYTE\" in /boot/loader.conf) to \
- build with Java support." | ${FMT} -s; \
- exit 1; \
- fi
-.endif
pre-extract:
@# Building libgcj with lang/gcc295 installed is causing a failure
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index 658a1b116cc7..c659957b834b 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -137,15 +137,6 @@ PLIST_SUB+= JAVA="@comment "
pre-everything::
@${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
-.if ! defined(WITHOUT_JAVA)
- @DSIZ=700000; DSIZBYTE=734003200; \
- if [ `ulimit -d` -lt $$DSIZ ]; then \
- echo "You need to increase the datasize limit to at least $$DSIZ \
- (and set kern.maxdsiz=\"$$DSIZBYTE\" in /boot/loader.conf) to \
- build with Java support." | ${FMT} -s; \
- exit 1; \
- fi
-.endif
pre-extract:
@# Building libgcj with lang/gcc295 installed is causing a failure
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 658a1b116cc7..c659957b834b 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -137,15 +137,6 @@ PLIST_SUB+= JAVA="@comment "
pre-everything::
@${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
-.if ! defined(WITHOUT_JAVA)
- @DSIZ=700000; DSIZBYTE=734003200; \
- if [ `ulimit -d` -lt $$DSIZ ]; then \
- echo "You need to increase the datasize limit to at least $$DSIZ \
- (and set kern.maxdsiz=\"$$DSIZBYTE\" in /boot/loader.conf) to \
- build with Java support." | ${FMT} -s; \
- exit 1; \
- fi
-.endif
pre-extract:
@# Building libgcj with lang/gcc295 installed is causing a failure
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 658a1b116cc7..c659957b834b 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -137,15 +137,6 @@ PLIST_SUB+= JAVA="@comment "
pre-everything::
@${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
-.if ! defined(WITHOUT_JAVA)
- @DSIZ=700000; DSIZBYTE=734003200; \
- if [ `ulimit -d` -lt $$DSIZ ]; then \
- echo "You need to increase the datasize limit to at least $$DSIZ \
- (and set kern.maxdsiz=\"$$DSIZBYTE\" in /boot/loader.conf) to \
- build with Java support." | ${FMT} -s; \
- exit 1; \
- fi
-.endif
pre-extract:
@# Building libgcj with lang/gcc295 installed is causing a failure