aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-07-10 17:08:17 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-07-10 17:08:17 +0000
commit1c3762d85bb8e964a218dd815a4d56ba098405eb (patch)
tree8464af64dc29fb16503d0d391e8e69a1d6c707f8
parentbf26c28e8ccd9f460bb2c8678988355ffa95c56b (diff)
downloadports-1c3762d85bb8e964a218dd815a4d56ba098405eb.tar.gz
ports-1c3762d85bb8e964a218dd815a4d56ba098405eb.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/sbd/Makefile28
-rw-r--r--net/sbd/distinfo2
-rw-r--r--net/sbd/files/patch-aa19
-rw-r--r--net/sbd/pkg-descr17
5 files changed, 67 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index afab0f14b2ac..e9f646f6de4d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -608,6 +608,7 @@
SUBDIR += samba3
SUBDIR += sambasentinel
SUBDIR += samplicator
+ SUBDIR += sbd
SUBDIR += scand
SUBDIR += scr_ipfm
SUBDIR += sdl_net
diff --git a/net/sbd/Makefile b/net/sbd/Makefile
new file mode 100644
index 000000000000..9dc7c4d79cf5
--- /dev/null
+++ b/net/sbd/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: sbd
+# Date created: 2004-07-08
+# Whom: David Thiel (lx@redundancy.redundancy.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= sbd
+PORTVERSION= 1.31
+CATEGORIES= net security
+MASTER_SITES= http://www.cycom.se/uploads/114/31/
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= A netcat clone with more features and crypto
+
+ALL_TARGET= unix
+
+PLIST_FILES= bin/sbd
+PORTDOCS= README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sbd ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/sbd/distinfo b/net/sbd/distinfo
new file mode 100644
index 000000000000..85cbf24ac30b
--- /dev/null
+++ b/net/sbd/distinfo
@@ -0,0 +1,2 @@
+MD5 (sbd-1.31.tar.gz) = fde99ed6c7dc2729751eead5d6bee538
+SIZE (sbd-1.31.tar.gz) = 859963
diff --git a/net/sbd/files/patch-aa b/net/sbd/files/patch-aa
new file mode 100644
index 000000000000..5a678983e505
--- /dev/null
+++ b/net/sbd/files/patch-aa
@@ -0,0 +1,19 @@
+--- Makefile.orig Sat Jul 10 18:52:02 2004
++++ Makefile Sat Jul 10 18:53:56 2004
+@@ -1,15 +1,13 @@
+-CC = gcc
+ MAKE = make
+
+ # extra flags
+-CFLAGS=
+ LDFLAGS=
+
+ # cflags
+
+ WIN_CFLAGS = -Wall -Wshadow -O2 -DWIN32
+ WINMAIN_CFLAGS = -mwindows -Wall -Wshadow -O2 -DWIN32 -DWINMAIN
+-UNIX_CFLAGS = -Wall -Wshadow -O2
++UNIX_CFLAGS = -Wall -Wshadow
+
+ # ldflags
+
diff --git a/net/sbd/pkg-descr b/net/sbd/pkg-descr
new file mode 100644
index 000000000000..10225613d3af
--- /dev/null
+++ b/net/sbd/pkg-descr
@@ -0,0 +1,17 @@
+sbd is a Netcat-clone, designed to be portable and offer strong
+encryption. It runs on Unix-like operating systems and on Microsoft
+Win32. sbd features AES-CBC-128 + HMAC-SHA1 encryption (by Christophe
+Devine), program execution (-e option), choosing source port, continuous
+reconnection with delay, and some other nice features. Only TCP/IP
+communication is supported. Source code and binaries are distributed
+under the GNU General Public License.
+
+sbd can be used for any number of network-related things, e.g.:
+
+ * Secure file transfer
+ * Remote administration
+ * Simple (but secure) peer-to-peer chat
+ * Pen-test tool (crypto avoids NIDS detection and telnet-style
+ traffic recording)
+
+WWW: http://www.cycom.se/dl/sbd