aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-23 17:06:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-23 17:06:40 +0000
commit271ee243cdd9b79bd45a24daca5bbc0778dbd9f3 (patch)
tree8227a58ddb44c6e0243ad830d0554f91d8ff5afe
parent9ae9183f34dc3e96ff696c8328b07faf18c39d2c (diff)
downloadports-271ee243cdd9b79bd45a24daca5bbc0778dbd9f3.tar.gz
ports-271ee243cdd9b79bd45a24daca5bbc0778dbd9f3.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-CommandLine/Makefile26
-rw-r--r--www/p5-Catalyst-Plugin-CommandLine/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-CommandLine/pkg-descr4
-rw-r--r--www/p5-Catalyst-Plugin-CommandLine/pkg-plist7
5 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 81e7bc8357a4..a5b572a59f1c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -738,6 +738,7 @@
SUBDIR += p5-Catalyst-Plugin-Cache-Memcached-Fast
SUBDIR += p5-Catalyst-Plugin-Cache-Store-FastMmap
SUBDIR += p5-Catalyst-Plugin-Captcha
+ SUBDIR += p5-Catalyst-Plugin-CommandLine
SUBDIR += p5-Catalyst-Plugin-ConfigLoader
SUBDIR += p5-Catalyst-Plugin-ConfigLoader-Environment
SUBDIR += p5-Catalyst-Plugin-CookiedSession
diff --git a/www/p5-Catalyst-Plugin-CommandLine/Makefile b/www/p5-Catalyst-Plugin-CommandLine/Makefile
new file mode 100644
index 000000000000..366075a8693d
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-CommandLine/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Catalyst-Plugin-CommandLine
+# Date created: Wed 22 Apr 2009
+# Whom: Alexey V. Degtyarev <alexey@renatasystems.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-CommandLine
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Catalyst plugin to make controllers or models available for scripts
+
+BUILD_DEPENDS= ${SITE_PERL}/Catalyst.pm:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ ${SITE_PERL}/URI/http.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/HTTP/Headers.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::CommandLine.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Plugin-CommandLine/distinfo b/www/p5-Catalyst-Plugin-CommandLine/distinfo
new file mode 100644
index 000000000000..4e5b73bf3a48
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-CommandLine/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-CommandLine-0.05.tar.gz) = b88626d1d8cec8bf5b9a36b91c08d936
+SHA256 (Catalyst-Plugin-CommandLine-0.05.tar.gz) = 05d5d45aad97b86689203125544b04b8d64e76ee9df1a4a31b3a7dafc28bb2d1
+SIZE (Catalyst-Plugin-CommandLine-0.05.tar.gz) = 4314
diff --git a/www/p5-Catalyst-Plugin-CommandLine/pkg-descr b/www/p5-Catalyst-Plugin-CommandLine/pkg-descr
new file mode 100644
index 000000000000..deb9d0a97736
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-CommandLine/pkg-descr
@@ -0,0 +1,4 @@
+Use this module if you need to have access to the Catalyst controllers or
+models from command line script.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-CommandLine/
diff --git a/www/p5-Catalyst-Plugin-CommandLine/pkg-plist b/www/p5-Catalyst-Plugin-CommandLine/pkg-plist
new file mode 100644
index 000000000000..3d27e09df753
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-CommandLine/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Catalyst/Plugin/CommandLine.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/CommandLine/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/CommandLine
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst