aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-06-29 15:13:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-06-29 15:13:19 +0000
commita558961425f3ff725aa0f330e60a5551a4ae5357 (patch)
tree037c0b92d2989a8e1225b88a5ce2727c474f5a04
parentde98569d5ec970f60737a840a148cf059cf2a3d7 (diff)
Notes
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/manu-gothica/Makefile43
-rw-r--r--x11-fonts/manu-gothica/distinfo3
-rw-r--r--x11-fonts/manu-gothica/pkg-descr6
-rw-r--r--x11-fonts/manu-gothica/pkg-plist2
5 files changed, 55 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 35b189631ebb..684109ad8067 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -40,6 +40,7 @@
SUBDIR += lfpfonts-var
SUBDIR += libXft
SUBDIR += linux-fontconfig
+ SUBDIR += manu-gothica
SUBDIR += mathfonts
SUBDIR += mgopen
SUBDIR += mkbold
diff --git a/x11-fonts/manu-gothica/Makefile b/x11-fonts/manu-gothica/Makefile
new file mode 100644
index 000000000000..971db0380f6a
--- /dev/null
+++ b/x11-fonts/manu-gothica/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: manu-gothica
+# Date created: 2006-04-02
+# Whom: heiner Eichmann <h.eichmann@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= manu-gothica
+DISTVERSION= 0
+CATEGORIES= x11-fonts
+MASTER_SITES= http://www.bryld.info/downloads/
+DISTNAME= manugot19
+EXTRACT_SUFX= .ttf
+
+MAINTAINER= h.eichmann@gmx.de
+COMMENT= Old german blackletter handwriting (suetterlin)
+
+BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+RESTRICTED= The font is free for personal use
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKSRC}
+USE_X_PREFIX= yes
+NO_BUILD= yes
+
+NO_WRKSUBDIR= yes
+FONTSDIR= lib/X11/fonts/TTF/
+PLIST_SUB+= FONTSDIR=${FONTSDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/manugot19.ttf ${PREFIX}/${FONTSDIR}/manugot19.ttf
+
+post-install:
+ @${ECHO_MSG} "===> Running fc-cache"
+ -${X11BASE}/bin/fc-cache -f -v ${PREFIX}/${FONTSDIR}
+ @${ECHO_MSG}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/manu-gothica/distinfo b/x11-fonts/manu-gothica/distinfo
new file mode 100644
index 000000000000..2d72073ad4a1
--- /dev/null
+++ b/x11-fonts/manu-gothica/distinfo
@@ -0,0 +1,3 @@
+MD5 (manugot19.ttf) = c3ec7ef63454bea8c4ccfa89d8980158
+SHA256 (manugot19.ttf) = 7049b299a76aacc06fba9c3f0a5e3f36521f28922a77f6b4e7ff57468ac1fca7
+SIZE (manugot19.ttf) = 60296
diff --git a/x11-fonts/manu-gothica/pkg-descr b/x11-fonts/manu-gothica/pkg-descr
new file mode 100644
index 000000000000..1aa3c5ec442c
--- /dev/null
+++ b/x11-fonts/manu-gothica/pkg-descr
@@ -0,0 +1,6 @@
+This True Type Font has been based on the Old German handwriting as it
+was taught in Schleswig and Germany around Year 1900 (Suetterlin). If
+you study sources from that time and before, it is important to be
+familiar with this writing style. The font is free for personal use.
+
+WWW: http://www.bryld.info/download.php
diff --git a/x11-fonts/manu-gothica/pkg-plist b/x11-fonts/manu-gothica/pkg-plist
new file mode 100644
index 000000000000..cf0d77846bc0
--- /dev/null
+++ b/x11-fonts/manu-gothica/pkg-plist
@@ -0,0 +1,2 @@
+@exec %D/bin/fc-cache -f -v %%FONTSDIR%%
+%%FONTSDIR%%/manugot19.ttf