aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-07-04 07:51:56 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-07-04 07:51:56 +0000
commit0a858b6b9ae50ec8a785f7f128c8e87c1f6f0a06 (patch)
tree4cc9a2e83ef0cade1d449cbba998fd597729a193
parent4991f4c86f5696bcd883509f14fe82d162f6c27c (diff)
downloadports-0a858b6b9ae50ec8a785f7f128c8e87c1f6f0a06.tar.gz
ports-0a858b6b9ae50ec8a785f7f128c8e87c1f6f0a06.zip
Notes
-rw-r--r--science/hdf/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index d6b0f36541db..85960f3ccf0f 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -27,10 +27,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
CONFLICTS= netcdf-*
-BROKEN= libtool problem
-
WANT_FORTRAN= yes
-#USE_GCC=4.2+
BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
FC= gfortran42
F77= gfortran42
@@ -38,7 +35,9 @@ F77= gfortran42
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS+=--with-jpeg="${LOCALBASE}" \
--with-szlib="${LOCALBASE}"
-CONFIGURE_ENV+= F77="${F77}" FFLAGS="${FFLAGS}"
+#wiredness of F77, FC in hdf/src/Makefile
+CONFIGURE_ENV+= F77="f77" FC="f77" FFLAGS="${FFLAGS}"
+MAKE_ENV+= PATH="${WRKSRC}/bin:${PATH}"
DOCFILES= HDF41r5_SpecDG.pdf \
HDF42r0_RefMan.pdf \
HDF42r0_UserGd.pdf
@@ -59,6 +58,10 @@ post-patch:
${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:" \
${WRKSRC}/hdf/src/Makefile.in ${WRKSRC}/mfhdf/libsrc/Makefile.in
+#wiredness of F77, FC in hdf/src/Makefile
+pre-configure:
+ ${LN} -s `${WHICH} ${FC}` ${WRKSRC}/bin/f77
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}