aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremie Le Hen <jlh@FreeBSD.org>2017-07-01 09:07:19 +0000
committerJeremie Le Hen <jlh@FreeBSD.org>2017-07-01 09:07:19 +0000
commit19937e4d260d497df09d0d0f0b39205aca4614ed (patch)
tree5424b315741ec240097b4cff27443db2a03dcf16
parentc85557f7d569792e2f5767c912d3cbebfb0b04e4 (diff)
downloadports-19937e4d260d497df09d0d0f0b39205aca4614ed.tar.gz
ports-19937e4d260d497df09d0d0f0b39205aca4614ed.zip
Add net/bsdrcmds.
This ports contains FreeBSD's "rmds" which were originally part of the base system. Reviewed by: jbeich@, matthew@ Approved by: jbeich@, matthew@ Differential Revision: https://reviews.freebsd.org/D11345
Notes
Notes: svn path=/head/; revision=444814
-rw-r--r--net/Makefile1
-rw-r--r--net/bsdrcmds/Makefile30
-rw-r--r--net/bsdrcmds/distinfo3
-rw-r--r--net/bsdrcmds/pkg-descr10
-rw-r--r--net/bsdrcmds/pkg-plist16
5 files changed, 60 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index afbcfa19acc2..bb6df5f9d06d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -61,6 +61,7 @@
SUBDIR += bounce
SUBDIR += bsdec2-image-upload
SUBDIR += bsdproxy
+ SUBDIR += bsdrcmds
SUBDIR += bwi-firmware-kmod
SUBDIR += bwn-firmware-kmod
SUBDIR += bwping
diff --git a/net/bsdrcmds/Makefile b/net/bsdrcmds/Makefile
new file mode 100644
index 000000000000..285a06f54078
--- /dev/null
+++ b/net/bsdrcmds/Makefile
@@ -0,0 +1,30 @@
+# Created by: Jeremie Le Hen <jlh@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= bsdrcmds
+PORTVERSION= 20170627
+CATEGORIES= net
+MASTER_SITES= LOCAL/jlh
+
+MAINTAINER= jlh@FreeBSD.org
+COMMENT= FreeBSD rcmds (rcp/rlogin/rlogind/rsh/rshd/ruptime/rwho/rwhod)
+
+LICENSE= BSD3CLAUSE
+
+USES= tar:xz uidfix
+
+MAKE_ARGS+= BINOWN=${BINOWN} BINMODE=${BINMODE}
+MAKE_ENV+= NO_WERROR=1
+
+OPTIONS_DEFINE= IPV6 LIBBLACKLIST
+OPTIONS_DEFAULT= LIBBLACKLIST
+.if !exists(/usr/include/blacklist.h)
+OPTIONS_EXCLUDE= LIBBLACKLIST
+.endif
+
+IPV6_MAKE_ARGS= USE_IPV6=yes
+
+LIBBLACKLIST_DESC= libblacklist(3) support for rlogind(8) and rshd(8)
+LIBBLACKLIST_MAKE_ARGS= USE_LIBBLACKLIST=yes
+
+.include <bsd.port.mk>
diff --git a/net/bsdrcmds/distinfo b/net/bsdrcmds/distinfo
new file mode 100644
index 000000000000..a6a91bed2bd3
--- /dev/null
+++ b/net/bsdrcmds/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1498577522
+SHA256 (bsdrcmds-20170627.tar.xz) = 731ea0afef630bba4bb22ddfabfac1ac55510e8b1fd7bf14920839740fdcd831
+SIZE (bsdrcmds-20170627.tar.xz) = 35072
diff --git a/net/bsdrcmds/pkg-descr b/net/bsdrcmds/pkg-descr
new file mode 100644
index 000000000000..3f3a38ab564d
--- /dev/null
+++ b/net/bsdrcmds/pkg-descr
@@ -0,0 +1,10 @@
+This is a port of the BSD "rcmds", which were formerly part of the
+FreeBSD base system. This port includes the following binaries:
+rcp(1)
+rlogin(1)
+rlogind(8)
+rsh(1)
+rshd(8)
+ruptime(1)
+rwho(1)
+rwhod(8)
diff --git a/net/bsdrcmds/pkg-plist b/net/bsdrcmds/pkg-plist
new file mode 100644
index 000000000000..be34efdff142
--- /dev/null
+++ b/net/bsdrcmds/pkg-plist
@@ -0,0 +1,16 @@
+bin/ruptime
+@(,,4555) bin/rsh
+bin/rwho
+@(,,4555) bin/rlogin
+@(,,4555) bin/rcp
+man/man8/rlogind.8.gz
+man/man8/rshd.8.gz
+man/man8/rwhod.8.gz
+man/man1/rsh.1.gz
+man/man1/ruptime.1.gz
+man/man1/rlogin.1.gz
+man/man1/rwho.1.gz
+man/man1/rcp.1.gz
+sbin/rwhod
+sbin/rlogind
+sbin/rshd