aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-07-06 05:34:14 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-07-06 05:34:14 +0000
commit64f9316bd8c0d76d46cfd079bc79f839f33d8153 (patch)
treeab4b84a3b12ef15b8bf55bc730883266f076c132
parent6a56381dfc01164f6b4af14a14347aae457f0ad9 (diff)
downloadports-64f9316bd8c0d76d46cfd079bc79f839f33d8153.tar.gz
ports-64f9316bd8c0d76d46cfd079bc79f839f33d8153.zip
MFH: r445053
Only use enable-ec_nistp_64_gcc_128 on amd64 since it requires a 64-bit little-endian architecture and fix the build on !amd64 ecp_nistp224.c:43:9: error: unknown type name '__uint128_t' typedef __uint128_t uint128_t; /* nonstandard; implemented by gcc on 64-bit ^ PR: 220403 Reported by: dewayne@heuristicsystems.com.au Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D11436 Approved by: ports-secteam (blanket)
Notes
Notes: svn path=/branches/2017Q3/; revision=445128
-rw-r--r--security/testssl.sh/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/security/testssl.sh/Makefile b/security/testssl.sh/Makefile
index efdfb7497c38..a2e52793c41a 100644
--- a/security/testssl.sh/Makefile
+++ b/security/testssl.sh/Makefile
@@ -2,6 +2,7 @@
PORTNAME= testssl.sh
PORTVERSION= 2.8
+PORTREVISION= 1
CATEGORIES= security
MAINTAINER= tobik@FreeBSD.org
@@ -44,7 +45,6 @@ CONFIGURE_ARGS= --openssldir=${OPENSSLDIR} \
enable-camellia \
enable-idea \
enable-rfc3779 \
- enable-ec_nistp_64_gcc_128 \
experimental-jpake \
-DOPENSSL_USE_IPV6
CONFIGURE_ENV= PERL="${PERL}"
@@ -57,6 +57,14 @@ CONFIGURE_WRKSRC= ${WRKSRC_openssl}
# unknown reasons.
MAKE_JOBS_UNSAFE= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CONFIGURE_ARGS+= enable-ec_nistp_64_gcc_128
+.else
+CONFIGURE_ARGS+= no-ec_nistp_64_gcc_128
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/elif test_openssl_suffix/d' \
-e 's@: \# 5. we tried.*$$@else OPENSSL="${PREFIX}/libexec/openssl.testssl.sh"@' \
@@ -71,4 +79,4 @@ do-install:
@cd ${WRKSRC}/etc && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/etc
@cd ${WRKSRC}/utils && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/utils
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>