aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-07-02 23:26:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-07-02 23:26:19 +0000
commit86d451acc014405bac132ff7e57dcb9bd255b500 (patch)
tree2340ec0abc6f84879ea1f76a2dcd16b6a70a8a5e
parent1b3fcd839001ade1788f938e7fcacf14486d6535 (diff)
downloadports-86d451acc014405bac132ff7e57dcb9bd255b500.tar.gz
ports-86d451acc014405bac132ff7e57dcb9bd255b500.zip
MFH: r444907
devel/android-tools-fastboot-devel: drop unused file after r422901 Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2017Q3/; revision=444908
-rw-r--r--devel/android-tools-fastboot-devel/files/Makefile1
-rw-r--r--devel/android-tools-fastboot-devel/files/util_freebsd.cpp39
2 files changed, 0 insertions, 40 deletions
diff --git a/devel/android-tools-fastboot-devel/files/Makefile b/devel/android-tools-fastboot-devel/files/Makefile
index b8bf685f5cd2..82ef3a1d91d9 100644
--- a/devel/android-tools-fastboot-devel/files/Makefile
+++ b/devel/android-tools-fastboot-devel/files/Makefile
@@ -18,7 +18,6 @@ SRCS+= util.cpp
.PATH: ${EXTRADIR}
SRCS+= usb_freebsd.cpp
-SRCS+= util_freebsd.cpp
# required by fastboot
.PATH: ${.CURDIR}/../adb
diff --git a/devel/android-tools-fastboot-devel/files/util_freebsd.cpp b/devel/android-tools-fastboot-devel/files/util_freebsd.cpp
deleted file mode 100644
index 0734454a9c85..000000000000
--- a/devel/android-tools-fastboot-devel/files/util_freebsd.cpp
+++ /dev/null
@@ -1,39 +0,0 @@
-/*
- * Copyright (C) 2011 Hans Petter Selasky. All rights reserved.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- * * Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * * Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in
- * the documentation and/or other materials provided with the
- * distribution.
- *
- * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
- * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
- * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
- * FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
- * COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
- * INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
- * BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
- * OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
- * AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
- * OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
- * OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
- * SUCH DAMAGE.
- */
-
-#include "fastboot.h"
-
-#include <unistd.h>
-#include <limits.h>
-
-std::string
-get_my_path()
-{
- char path[PATH_MAX + 1];
- getcwd(path, sizeof(path) - 1);
- return path;
-}