aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-03 14:58:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-03 14:58:35 +0000
commitc346c57440c83fd30bd6f0b856fedda8416cce92 (patch)
tree6997dced9aa8b2e403235327e6adc4a7b2dd6ac4
parent99ceb3208a2463760ebe1651d68e0cff9e6ff596 (diff)
downloadports-c346c57440c83fd30bd6f0b856fedda8416cce92.tar.gz
ports-c346c57440c83fd30bd6f0b856fedda8416cce92.zip
MFH: r444956
Commit the patch forgotten in the previous commit: "- Modify the port to never send data to fbsdmon.org, bump PORTREVISION" PR: 217099 Submitted by: asomers Approved by: ports-secteam (with hat)
Notes
Notes: svn path=/branches/2017Q3/; revision=444960
-rw-r--r--ports-mgmt/fbsdmon/Makefile2
-rw-r--r--ports-mgmt/fbsdmon/files/patch-src_io.c18
2 files changed, 19 insertions, 1 deletions
diff --git a/ports-mgmt/fbsdmon/Makefile b/ports-mgmt/fbsdmon/Makefile
index a4347d93a7ea..fee6efbcd9f2 100644
--- a/ports-mgmt/fbsdmon/Makefile
+++ b/ports-mgmt/fbsdmon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fbsdmon
PORTVERSION= 1.01
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ports-mgmt sysutils
MASTER_SITES= LOCAL/gblach/
diff --git a/ports-mgmt/fbsdmon/files/patch-src_io.c b/ports-mgmt/fbsdmon/files/patch-src_io.c
new file mode 100644
index 000000000000..260471c80648
--- /dev/null
+++ b/ports-mgmt/fbsdmon/files/patch-src_io.c
@@ -0,0 +1,18 @@
+--- src/io.c.orig 2014-09-06 23:04:23 UTC
++++ src/io.c
+@@ -16,6 +16,15 @@ extern char *fbsdmon_url(char *path)
+ if(NULL != prefix) prefix = strdup(prefix);
+ else prefix = strdup("http://fbsdmon.org/");
+
++ if (strstr(prefix, "fbsdmon.org") != NULL) {
++ fprintf(stderr, "fbsdmon is no longer supported, and the "
++ "web site it sends data to (http://fbsdmon.org/), "
++ "has been taken over by cybersquatters. Refusing "
++ "to send system info to an unknown party. Please "
++ "deinstall fbsdmon package.\n\n");
++ exit(1);
++ }
++
+ char *url = malloc(strlen(prefix) + strlen(path) + 1);
+ bzero(url, 1);
+ strcat(url, prefix);