aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-01 09:00:16 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-01 09:00:16 +0000
commitc85557f7d569792e2f5767c912d3cbebfb0b04e4 (patch)
tree5a0239269907522d32168bd5d6f06184c2d5d423
parentef64c49347f95571020ac224ed6f9805c3f1298f (diff)
downloadports-c85557f7d569792e2f5767c912d3cbebfb0b04e4.tar.gz
ports-c85557f7d569792e2f5767c912d3cbebfb0b04e4.zip
- Unsilence installation commands
- Switch to options helpers Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=444813
-rw-r--r--www/webreport/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/www/webreport/Makefile b/www/webreport/Makefile
index 3ced443778c6..dcc035a5c443 100644
--- a/www/webreport/Makefile
+++ b/www/webreport/Makefile
@@ -14,23 +14,20 @@ SUB_FILES= pkg-message
PORTDOCS= INSTALL
PLIST_FILES= bin/webreport etc/webreport.conf-dist
-OPTIONS_DEFINE= DOCS
-
# silence clang errors on 10.0+
CFLAGS+= -Wno-return-type
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's,ulong,unsigned long,;s,/etc/,${PREFIX}/etc/,' ${WRKSRC}/webreport.h
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/webreport ${STAGEDIR}${PREFIX}/bin
- @${INSTALL_DATA} ${WRKSRC}/webreport.conf ${STAGEDIR}${PREFIX}/etc/webreport.conf-dist
+ ${INSTALL_PROGRAM} ${WRKSRC}/webreport ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/webreport.conf ${STAGEDIR}${PREFIX}/etc/webreport.conf-dist
-.if ${PORT_OPTIONS:MDOCS}
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_MAN} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>