aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-10-05 12:24:29 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-10-05 12:24:29 +0000
commit5cfecd3fbc6863358c7258470562641f46c2ddd5 (patch)
treea32d825d5d974790682a5b3aa480fa19ea96ad4a
parent4595722a6dce73220f528cbc71805243022e008f (diff)
downloadports-5cfecd3fbc6863358c7258470562641f46c2ddd5.tar.gz
ports-5cfecd3fbc6863358c7258470562641f46c2ddd5.zip
MFH: r551474
devel/bmake: disable cmd-interrupt test in batch builds This fixes the build under modern poudriere, but continues to run the test in all other environments so that we *can* catch issues here if they arise. The breakage should get fixed on the poudriere or base sh(1) side, but this will not necessarily be done soon. Reported by: mjg Approved by: portmgr (implicit, bulk fix) Approved by: ports-secteam (implicit, build fix)
Notes
Notes: svn path=/branches/2020Q4/; revision=551488
-rw-r--r--devel/bmake/Makefile4
-rw-r--r--devel/bmake/files/extrapatch-unit-tests_Makefile11
2 files changed, 15 insertions, 0 deletions
diff --git a/devel/bmake/Makefile b/devel/bmake/Makefile
index 30274d998872..1bb9d03597b6 100644
--- a/devel/bmake/Makefile
+++ b/devel/bmake/Makefile
@@ -17,6 +17,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ENV+= CONFIG_SITE=${CONFIG_SITE}
+.if defined(BATCH)
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-unit-tests_Makefile
+.endif
+
post-patch: .SILENT
${REINPLACE_CMD} 's/^\.Nx/NetBSD/' ${WRKDIR}/bmake/bmake.1
diff --git a/devel/bmake/files/extrapatch-unit-tests_Makefile b/devel/bmake/files/extrapatch-unit-tests_Makefile
new file mode 100644
index 000000000000..891268ce7600
--- /dev/null
+++ b/devel/bmake/files/extrapatch-unit-tests_Makefile
@@ -0,0 +1,11 @@
+--- unit-tests/Makefile.orig 2020-10-05 03:28:18 UTC
++++ unit-tests/Makefile
+@@ -36,7 +36,7 @@
+ # src/tests/usr.bin/make/t_make.sh as well.
+ TESTS+= # archive # broken on FreeBSD, enabled in t_make.sh
+ TESTS+= archive-suffix
+-TESTS+= cmd-interrupt
++TESTS+= # cmd-interrupt
+ TESTS+= cmdline
+ TESTS+= comment
+ TESTS+= cond-cmp-numeric