aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-02-24 06:31:05 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-02-24 06:31:05 +0000
commit48fcfab00fc4fd3550be91fc98e3c9962f1b3dfe (patch)
tree26fc2dee1db4a4dbffdff1b9bdd23b626fae24cb
parentfcd9c2bfea213a9551365f6bb91e99bd60cbc4f2 (diff)
downloadports-48fcfab00fc4fd3550be91fc98e3c9962f1b3dfe.tar.gz
ports-48fcfab00fc4fd3550be91fc98e3c9962f1b3dfe.zip
MFH: r566449
net/widentd: Replace deprecated variable (fixes build) PR: 253240 Submitted by: portmaster@bsdforge.com (maintainer)
Notes
Notes: svn path=/branches/2021Q1/; revision=566450
-rw-r--r--net/widentd/Makefile10
-rw-r--r--net/widentd/files/patch-widentd.c11
2 files changed, 19 insertions, 2 deletions
diff --git a/net/widentd/Makefile b/net/widentd/Makefile
index 861a711ce9a7..be53a749bcbb 100644
--- a/net/widentd/Makefile
+++ b/net/widentd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= widentd
PORTVERSION= 1.04
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://BSDforge.com/projects/source/net/widentd/
@@ -12,10 +13,15 @@ COMMENT= RFC1413 auth/identd daemon providing a fixed fake reply
LICENSE= BSD3CLAUSE
USES= ncurses uidfix tar:xz
+USE_RC_SUBR= widentd
MAKE_ENV+= BINDIR="${PREFIX}/sbin" MANDIR="${PREFIX}/man/man"
-MAKE_ENV+= NO_WERROR="defined"
PLIST_FILES= sbin/widentd man/man8/widentd.8.gz
-USE_RC_SUBR= widentd
.include <bsd.port.mk>
+
+.if ${OSREL:R} < 13
+MAKE_ENV+=NO_WERROR=1
+.else
+MAKE_ENV+=MK_WERROR=no
+.endif
diff --git a/net/widentd/files/patch-widentd.c b/net/widentd/files/patch-widentd.c
new file mode 100644
index 000000000000..e91450cad30a
--- /dev/null
+++ b/net/widentd/files/patch-widentd.c
@@ -0,0 +1,11 @@
+--- widentd.c.orig 2015-02-24 19:27:09 UTC
++++ widentd.c
+@@ -191,7 +191,7 @@ main(int argc, char **argv)
+
+ to.tv_sec = TIMEOUT;
+ to.tv_usec = 0;
+- memset(buff, sizeof(buff), 0);
++ memset(buff, (0), sizeof(buff));
+ do {
+ int n;
+