aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-03-01 22:59:35 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-03-01 22:59:35 +0000
commit72f2119489af8bb6a38db25dc2ee5694759f411f (patch)
tree125c7e066334e1bd0199c2d49b0d3eca64de1a5b
parent5bba9ff05728c40ee4b79437c789b3e0ce1d623d (diff)
downloadports-72f2119489af8bb6a38db25dc2ee5694759f411f.tar.gz
ports-72f2119489af8bb6a38db25dc2ee5694759f411f.zip
MFH: r566352
emulators/yuzu: prefer OpenSSL over GnuTLS after r560825 -- Found NETTLE: /usr/local/lib/libnettle.so -- Found GnuTLS: /usr/local/lib/libgnutls.so -- Found OpenSSL: /usr/lib/libcrypto.so (found version "1.1.1h") [...] Error: /usr/local/bin/yuzu is linked to /usr/local/lib/libgnutls.so.30 from security/gnutls but it is not declared as a dependency Warning: you need LIB_DEPENDS+=libgnutls.so:security/gnutls Error: /usr/local/bin/yuzu is linked to /usr/local/lib/libnettle.so.8 from security/nettle but it is not declared as a dependency Warning: you need LIB_DEPENDS+=libnettle.so:security/nettle
Notes
Notes: svn path=/branches/2021Q1/; revision=566921
-rw-r--r--emulators/yuzu-qt5/Makefile2
-rw-r--r--emulators/yuzu/Makefile3
2 files changed, 3 insertions, 2 deletions
diff --git a/emulators/yuzu-qt5/Makefile b/emulators/yuzu-qt5/Makefile
index c76e683cdde6..4bf1dce65d16 100644
--- a/emulators/yuzu-qt5/Makefile
+++ b/emulators/yuzu-qt5/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
PKGNAMESUFFIX= -qt5
MASTERDIR= ${.CURDIR}/../yuzu
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index 0f83dc729e24..06caf51c37f1 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -2,7 +2,7 @@
PORTNAME= yuzu
PORTVERSION= s20201218
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= emulators
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -49,6 +49,7 @@ GH_TUPLE= DarkLordZach:mbedtls:a280e60:mbedtls/externals/mbedtls \
USES= cmake compiler:c++17-lang localbase:ldflags sdl ssl
USE_SDL= sdl2
+CMAKE_OFF= ENABLE_GNUTLS ENABLE_MBEDTLS
LDFLAGS+= -Wl,--as-needed # Qt5Network
TEST_TARGET= test