aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-02-24 14:18:27 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-02-24 14:18:27 +0000
commitf3ab7552b154e4b4406ce6e5bb7e205de4e2d9a7 (patch)
treea656c38486a4b3243c9a5c2798efa07b03e841f6
parentdf091c7c1f755a758c37faadfb8a0ccf0c2b5654 (diff)
downloadports-f3ab7552b154e4b4406ce6e5bb7e205de4e2d9a7.tar.gz
ports-f3ab7552b154e4b4406ce6e5bb7e205de4e2d9a7.zip
MFH: r566474
devel/newt: does not register shared libs pkg info -b newt does not show any shared libraries despite the port installing one. The framework uses the output of readelf -d to know if the library has a SONAME and this ports does not add a SONAME if it does not detect the GNU linker. Then, the resulting package does not register any shared libraries. * Patch configure.ac to learn and detect LLVM linker so it adds the SONAME to the library. * Add USE_LDCONFIG (portlint wrongly complains about not installing shared libs) PR: 253712 Submitted by: masamory7@gmail.com
Notes
Notes: svn path=/branches/2021Q1/; revision=566476
-rw-r--r--devel/newt/Makefile10
-rw-r--r--devel/newt/files/patch-configure.ac29
2 files changed, 33 insertions, 6 deletions
diff --git a/devel/newt/Makefile b/devel/newt/Makefile
index 022e6e1f6f6e..f40f89f16309 100644
--- a/devel/newt/Makefile
+++ b/devel/newt/Makefile
@@ -2,7 +2,7 @@
PORTNAME= newt
PORTVERSION= 0.52.20
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= https://releases.pagure.org/newt/
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libslang.so:devel/libslang2 \
libpopt.so:devel/popt
-USES= gmake ncurses pathfix
+USES= autoreconf gmake localbase ncurses pathfix
GNU_CONFIGURE= yes
MAKE_ENV= PCFLAGS="${CFLAGS}"
USE_LDCONFIG= yes
@@ -46,9 +46,7 @@ TCL_CPPFLAGS= -I${TCL_INCLUDEDIR:Q}
SOVERSION= ${PORTVERSION:R:E}
post-patch:
- @${REINPLACE_CMD} -e \
- '/^SONAME/s|=.*|=${SOVERSION}| ; \
- s|-DUSE_INTERP_RESULT||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-DUSE_INTERP_RESULT||' ${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e \
's|@CPP@|@CC@ -E| ; \
s|-D_GNU_SOURCE|| ; \
@@ -58,7 +56,7 @@ post-patch:
post-patch-PYTHON-on:
@${REINPLACE_CMD} -e \
- '/PYTHONVERS/s|=.*|=${PYTHON_VERSION}|' ${WRKSRC}/configure
+ '/PYTHONVERS/s|=.*|=${PYTHON_VERSION}|' ${WRKSRC}/configure.ac
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/whiptail
diff --git a/devel/newt/files/patch-configure.ac b/devel/newt/files/patch-configure.ac
new file mode 100644
index 000000000000..6d93d5cd8d6a
--- /dev/null
+++ b/devel/newt/files/patch-configure.ac
@@ -0,0 +1,29 @@
+--- configure.ac.orig 2017-03-17 10:36:31 UTC
++++ configure.ac
+@@ -2,7 +2,7 @@ AC_INIT([newt_pr.h])
+
+ PACKAGE=newt
+ VERSION=0.52.20
+-SONAME=0.52
++SONAME=52
+
+ AC_CONFIG_HEADER([config.h])
+
+@@ -24,7 +24,7 @@ AC_CHECK_SIZEOF([void *])
+ AC_MSG_CHECKING([for GNU ld])
+ LD=`$CC -print-prog-name=ld 2>&5`
+
+-if test `$LD -v 2>&1 | $ac_cv_path_GREP -c "GNU ld"` = 0; then
++if test `$LD -v 2>&1 | $ac_cv_path_GREP -c -E "GNU ld|compatible with GNU linkers"` = 0; then
+ # Not
+ GNU_LD=""
+ AC_MSG_RESULT([no])
+@@ -102,7 +102,7 @@ else
+ AC_SUBST([TCL_LIB_FLAG])
+ WHIPTCLLIB=whiptcl
+ # needed with tcl8.6
+- CPPFLAGS="$CPPFLAGS -DUSE_INTERP_RESULT"
++ CPPFLAGS="$CPPFLAGS "
+ else
+ AC_MSG_RESULT([NOT found])
+ fi