aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-10-05 20:44:11 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-10-05 20:44:11 +0000
commit3b5dd0eb9f43efd604d72ef0d311cd4135cf0c58 (patch)
tree1199851e310e33396684464a462900a163ce273e
parent5afd89e04ec28fabaddb8e0fe32c436554b9eea2 (diff)
downloadports-3b5dd0eb9f43efd604d72ef0d311cd4135cf0c58.tar.gz
ports-3b5dd0eb9f43efd604d72ef0d311cd4135cf0c58.zip
Notes
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/ratmenu/Makefile23
-rw-r--r--x11-wm/ratmenu/distinfo1
-rw-r--r--x11-wm/ratmenu/files/patch-Makefile18
-rw-r--r--x11-wm/ratmenu/pkg-comment1
-rw-r--r--x11-wm/ratmenu/pkg-descr3
-rw-r--r--x11-wm/ratmenu/pkg-plist1
7 files changed, 48 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 0573933d30f6..c42d46a5d896 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -47,6 +47,7 @@
SUBDIR += pwm
SUBDIR += qlwm
SUBDIR += qvwm
+ SUBDIR += ratmenu
SUBDIR += ratpoison
SUBDIR += sapphire
SUBDIR += sapphire-themes
diff --git a/x11-wm/ratmenu/Makefile b/x11-wm/ratmenu/Makefile
new file mode 100644
index 000000000000..108ff594ca15
--- /dev/null
+++ b/x11-wm/ratmenu/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ratmenu
+# Date created: Fri Oct 5 12:53:10 CDT 2001
+# Whom: mwm@mired.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= ratmenu
+PORTVERSION= 1.4
+CATEGORIES= x11-wm
+MASTER_SITES= http://reactor-core.org/~djw/
+
+MAINTAINER= mwm@mired.org
+
+USE_X_PREFIX= yes
+ALL_TARGET= ratmenu
+MAN1= ratmenu.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ratmenu ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ratmenu.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/x11-wm/ratmenu/distinfo b/x11-wm/ratmenu/distinfo
new file mode 100644
index 000000000000..5bfc58732f32
--- /dev/null
+++ b/x11-wm/ratmenu/distinfo
@@ -0,0 +1 @@
+MD5 (ratmenu-1.4.tar.gz) = 2b9571ff28a4252cbe2c258b9498504e
diff --git a/x11-wm/ratmenu/files/patch-Makefile b/x11-wm/ratmenu/files/patch-Makefile
new file mode 100644
index 000000000000..31b5a8b0cb16
--- /dev/null
+++ b/x11-wm/ratmenu/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig Wed Sep 26 14:36:26 2001
++++ Makefile Fri Oct 5 13:16:05 2001
+@@ -5,12 +5,9 @@
+
+ PROG = ratmenu
+
+-PREFIX=/usr/local
+-MANDIR=$(PREFIX)/man
+-
+-CC = gcc
+-LIBS = -L/usr/X11R6/lib -lX11
+-CFLAGS = -Os -Wall -ansi -pedantic
++MANDIR = $(PREFIX)/man
++CFLAGS += -I$(X11BASE)/include
++LIBS = -L$(X11BASE)/lib -lX11
+
+ $(PROG): $(PROG).c
+ $(CC) $(CFLAGS) $< $(LIBS) -o $@
diff --git a/x11-wm/ratmenu/pkg-comment b/x11-wm/ratmenu/pkg-comment
new file mode 100644
index 000000000000..c2924dd63f89
--- /dev/null
+++ b/x11-wm/ratmenu/pkg-comment
@@ -0,0 +1 @@
+A simple menu patterened for use with ratpoison
diff --git a/x11-wm/ratmenu/pkg-descr b/x11-wm/ratmenu/pkg-descr
new file mode 100644
index 000000000000..827c520ed67f
--- /dev/null
+++ b/x11-wm/ratmenu/pkg-descr
@@ -0,0 +1,3 @@
+This is ratmenu, a simple program that allows you to create X menus from the
+shell, where each menu item will run a command. ratmenu is intended for use
+with ratpoison, but can be used with any other window manager.
diff --git a/x11-wm/ratmenu/pkg-plist b/x11-wm/ratmenu/pkg-plist
new file mode 100644
index 000000000000..6f1617b52079
--- /dev/null
+++ b/x11-wm/ratmenu/pkg-plist
@@ -0,0 +1 @@
+bin/ratmenu