aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2007-03-05 15:26:21 +0000
committerDiane Bruce <db@FreeBSD.org>2007-03-05 15:26:21 +0000
commit4194da183983b93e201e8a969f1e9803b0f11e6b (patch)
tree6873c02211a47f58ca71262ef7c45c8060e95638
parent2c768e0103d783fd38174ad65a59f3b44242ea70 (diff)
downloadports-4194da183983b93e201e8a969f1e9803b0f11e6b.tar.gz
ports-4194da183983b93e201e8a969f1e9803b0f11e6b.zip
Notes
-rw-r--r--astro/Makefile1
-rw-r--r--astro/pyephem/Makefile27
-rw-r--r--astro/pyephem/distinfo3
-rw-r--r--astro/pyephem/pkg-descr12
-rw-r--r--astro/pyephem/pkg-plist3
5 files changed, 46 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 2c4170bce875..5308beb54d7f 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -52,6 +52,7 @@
SUBDIR += pp3
SUBDIR += ptiger
SUBDIR += py-metar
+ SUBDIR += pyephem
SUBDIR += pyweather
SUBDIR += rmap
SUBDIR += roadmap
diff --git a/astro/pyephem/Makefile b/astro/pyephem/Makefile
new file mode 100644
index 000000000000..8ecd71485dd9
--- /dev/null
+++ b/astro/pyephem/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: py-emphem
+# Date created: Feb 27, 2007
+# Whom: db
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyephem
+PORTVERSION= 3.7b
+CATEGORIES= astro math hamradio
+MASTER_SITES= http://www.rhodesmill.org/brandon/projects/ \
+ ${MASTER_SITE_LOCAL}
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= Scientific-grade astronomical computations for Python
+
+USE_PYTHON= 2.4+
+NO_BUILD= yes
+
+do-install:
+ (cd ${WRKSRC}; ${PYTHON_CMD} setup.py install)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/pyephem-manual.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/astro/pyephem/distinfo b/astro/pyephem/distinfo
new file mode 100644
index 000000000000..7424215f5f03
--- /dev/null
+++ b/astro/pyephem/distinfo
@@ -0,0 +1,3 @@
+MD5 (pyephem-3.7b.tar.gz) = 08ddcadfef79b6020d593b7665b4c3fa
+SHA256 (pyephem-3.7b.tar.gz) = f310597a3da24cf6799f233cf88914ae5d4ddb2dc8ed6e47cbf95a39fa0e9634
+SIZE (pyephem-3.7b.tar.gz) = 299901
diff --git a/astro/pyephem/pkg-descr b/astro/pyephem/pkg-descr
new file mode 100644
index 000000000000..c441d36ecffe
--- /dev/null
+++ b/astro/pyephem/pkg-descr
@@ -0,0 +1,12 @@
+PyEphem provides scientific-grade astronomical computations for the Python
+programming language. Given a date and location on the Earth's surface, it can
+compute the positions of the Sun and Moon, of the planets and their moons, and
+of any asteroids, comets, or earth satellites whose orbital elements the user
+can provide. Additional functions are provided to compute the angular
+separation between two objects in the sky, to determine the constellation in
+which an object lies, and to find the times at which an object rises, transits,
+and sets on a particular day.
+
+WWW: http://www.rhodesmill.org/brandon/projects/pyephem.html
+
+- Diane Bruce, VA3DB
diff --git a/astro/pyephem/pkg-plist b/astro/pyephem/pkg-plist
new file mode 100644
index 000000000000..0137b936b11f
--- /dev/null
+++ b/astro/pyephem/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/ephem.so
+%%PORTDOCS%%%%DOCSDIR%%/pyephem-manual.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%