aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorShane <FreeBSD@ShaneWare.Biz>2021-06-15 15:17:41 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2021-06-15 15:17:41 +0000
commit56c603914f70b67f04164958ab80f7a0ebd2c0e0 (patch)
tree17e32647add624dfe6979bc00c07ecc9f5a4222f
parentb0e101ec785b9a445e5beca3a5c8351a1537e810 (diff)
downloadports-56c603914f70b67f04164958ab80f7a0ebd2c0e0.tar.gz
ports-56c603914f70b67f04164958ab80f7a0ebd2c0e0.zip
devel/godot2: disable internal libs
Disable use of internal png, freetype and zlib. This matches ports for godot v3 and fixes build on powerpc64le. PR: 254867 Approved by: maintainer MFH: 2021Q2
-rw-r--r--devel/godot2/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/godot2/Makefile b/devel/godot2/Makefile
index 932e74247124..10f87d55c464 100644
--- a/devel/godot2/Makefile
+++ b/devel/godot2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= godot
DISTVERSION= 2.1.6
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONSUFFIX= -stable
CATEGORIES= devel games
PKGNAMESUFFIX?= 2
@@ -30,7 +30,9 @@ USE_GL= gl glu
USE_GITHUB= yes
GH_ACCOUNT= godotengine
-MAKE_ARGS+= platform=x11 builtin_speex=no builtin_libmpcdec=no verbose=yes builtin_libpng=no builtin_freetype=no builtin_zlib=no
+MAKE_ARGS+= platform=x11 builtin_freetype=no builtin_libmpcdec=no \
+ builtin_libpng=no builtin_openssl=no builtin_speex=no \
+ builtin_zlib=no verbose=yes
MAKE_ARGS+= ${MAKE_ARGS_${CHOSEN_COMPILER_TYPE}}
MAKE_ARGS_clang= use_llvm=yes
CXXFLAGS+= -DGLEW_NO_GLU -DRTAUDIO_ENABLED -DCRIOGET_NOT_NEEDED