aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Koczan <theis@gmx.at>2021-06-15 16:02:44 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2021-06-15 16:02:44 +0000
commitb48d2a658ef96565393b9186cbed85803b2b87e0 (patch)
treee223289eda456440b4c6f8b37bea12a4afa38ae3
parentbfa25459fcfaf5bcb4803ff598d72208fd920580 (diff)
downloadports-b48d2a658ef96565393b9186cbed85803b2b87e0.tar.gz
ports-b48d2a658ef96565393b9186cbed85803b2b87e0.zip
security/py-fail2ban: Create required start dir
Reported at https://github.com/fail2ban/fail2ban/issues/2634 fail2ban should check and, if necessary create, the required directory. It is still up to the user to ensure that configuration in fail2ban's conf files and FreeBSD's /etc/rc.conf are in sync and that both, pidfile and socket reside in the same directory. PR: 244092 Approved by: maintainer MFH: 2021Q2
-rw-r--r--security/py-fail2ban/Makefile1
-rw-r--r--security/py-fail2ban/files/fail2ban.in9
2 files changed, 10 insertions, 0 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index 017735a03578..cea038fdbc63 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -1,5 +1,6 @@
PORTNAME= fail2ban
PORTVERSION= 0.11.2
+PORTREVISION= 1
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-fail2ban/files/fail2ban.in b/security/py-fail2ban/files/fail2ban.in
index b20c0106dba5..a0cd0de97f5c 100644
--- a/security/py-fail2ban/files/fail2ban.in
+++ b/security/py-fail2ban/files/fail2ban.in
@@ -7,6 +7,9 @@
# Add the following lines to /etc/rc.conf to enable fail2ban:
# fail2ban_enable="YES"
# fail2ban_flags="<set as needed>"
+# fail2ban_pidfile="<same as in fail2ban.local>"
+
+# Make sure pidfile and socket point to the same directory
. /etc/rc.subr
@@ -15,12 +18,18 @@ PATH=${PATH}:%%PREFIX%%/sbin:%%PREFIX%%/bin
name="fail2ban"
rcvar=fail2ban_enable
+start_precmd="fail2ban_prestart"
command="%%PREFIX%%/bin/fail2ban-server"
command_interpreter="%%PYTHON_CMD%%"
client="%%PREFIX%%/bin/fail2ban-client"
extra_commands="reload jailstatus"
+fail2ban_prestart()
+{
+ install -d -m 0755 "$(dirname ${pidfile})"
+}
+
load_rc_config ${name}
#