aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-25 03:42:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-25 03:42:54 +0000
commitb9978e9f0286afdcf7315e03b5bda08b91a56140 (patch)
treecc1552bce82cefd8396bd073e63ce3a631aebeb5
parent04f9a046edbbfa6597d3d18ec514580e0499aa2e (diff)
downloadports-b9978e9f0286afdcf7315e03b5bda08b91a56140.tar.gz
ports-b9978e9f0286afdcf7315e03b5bda08b91a56140.zip
Notes
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/e17-module-news/Makefile36
-rw-r--r--x11-wm/e17-module-news/distinfo2
-rw-r--r--x11-wm/e17-module-news/pkg-descr4
-rw-r--r--x11-wm/e17-module-news/pkg-plist105
5 files changed, 148 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 14b4e5c837e1..b281f5037a2d 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -61,6 +61,7 @@
SUBDIR += e17-module-moon
SUBDIR += e17-module-mpdule
SUBDIR += e17-module-net
+ SUBDIR += e17-module-news
SUBDIR += e17-module-notification
SUBDIR += e17-module-penguins
SUBDIR += e17-module-photo
diff --git a/x11-wm/e17-module-news/Makefile b/x11-wm/e17-module-news/Makefile
new file mode 100644
index 000000000000..025a7ab53f3f
--- /dev/null
+++ b/x11-wm/e17-module-news/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-news
+# Date created: 29 January 2011
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= news
+PORTVERSION= 20110129
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2011-01-29/modules/
+PKGNAMEPREFIX= e17-module-
+
+MAINTAINER= magik@roorback.net
+COMMENT= A module to display information feeds like Rss
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e17-module-news/distinfo b/x11-wm/e17-module-news/distinfo
new file mode 100644
index 000000000000..4c3ba77e5b98
--- /dev/null
+++ b/x11-wm/e17-module-news/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/news-20110129.tar.bz2) = 7ada14ecbd6015e204c8a7f61e6f4aae4e35cd13e48931a6d66adf1411e5c677
+SIZE (e17/news-20110129.tar.bz2) = 972871
diff --git a/x11-wm/e17-module-news/pkg-descr b/x11-wm/e17-module-news/pkg-descr
new file mode 100644
index 000000000000..b12549b888ae
--- /dev/null
+++ b/x11-wm/e17-module-news/pkg-descr
@@ -0,0 +1,4 @@
+Module to display information feeds like Rss (and soon Atom)
+on Enlightenment 17 desktop.
+
+WWW: http://www.enlightenment.org/
diff --git a/x11-wm/e17-module-news/pkg-plist b/x11-wm/e17-module-news/pkg-plist
new file mode 100644
index 000000000000..b98b3b059c40
--- /dev/null
+++ b/x11-wm/e17-module-news/pkg-plist
@@ -0,0 +1,105 @@
+lib/enlightenment/modules/news/images/feeds/news.png
+lib/enlightenment/modules/news/images/feeds/osnews.png
+lib/enlightenment/modules/news/images/feeds/freshmeat.png
+lib/enlightenment/modules/news/images/feeds/cnn.png
+lib/enlightenment/modules/news/images/feeds/lemonde.png
+lib/enlightenment/modules/news/images/feeds/barrapunto.png
+lib/enlightenment/modules/news/images/feeds/meneame.png
+lib/enlightenment/modules/news/images/feeds/e_cvs.png
+lib/enlightenment/modules/news/images/feeds/futurasciences.png
+lib/enlightenment/modules/news/images/feeds/bouletcorp.png
+lib/enlightenment/modules/news/images/feeds/afp.png
+lib/enlightenment/modules/news/images/feeds/google.png
+lib/enlightenment/modules/news/images/feeds/digg.png
+lib/enlightenment/modules/news/images/feeds/slashdot.png
+lib/enlightenment/modules/news/images/feeds/courrierinternational.png
+lib/enlightenment/modules/news/images/feeds/google_fr.png
+lib/enlightenment/modules/news/images/feeds/default.png
+lib/enlightenment/modules/news/images/feeds/e_fr.png
+lib/enlightenment/modules/news/images/feeds/bbcworld.png
+lib/enlightenment/modules/news/images/categories/red.png
+lib/enlightenment/modules/news/images/categories/blue.png
+lib/enlightenment/modules/news/images/categories/default.png
+lib/enlightenment/modules/news/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/news/module.desktop
+lib/enlightenment/modules/news/e-module-news.edj
+%%NLS%%lib/enlightenment/modules/news/locale/bg/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/hr/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/pt_BR/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/hu/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/es/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/pl/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/he/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/ar/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/cs/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/nl/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/fr/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/zh_CN/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/el/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/uk/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/ja/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/de/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/ru/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/pt/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/sv/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/fi/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/eo/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/it/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/tr/LC_MESSAGES/news.mo
+%%NLS%%lib/enlightenment/modules/news/locale/sk/LC_MESSAGES/news.mo
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/sk/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/sk
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/tr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/tr
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/it/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/it
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/eo/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/eo
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/fi/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/fi
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/sv/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/sv
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/pt/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/pt
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/ru/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/ru
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/de/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/de
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/ja/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/ja
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/uk/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/uk
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/el/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/el
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/zh_CN/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/zh_CN
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/fr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/fr
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/nl/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/nl
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/cs/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/cs
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/ar/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/ar
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/he/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/he
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/pl/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/pl
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/es/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/es
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/hu/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/hu
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/pt_BR/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/pt_BR
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/hr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/hr
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/bg/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale/bg
+%%NLS%%@dirrm lib/enlightenment/modules/news/locale
+@dirrm lib/enlightenment/modules/news/%%E17_ARCH%%
+@dirrm lib/enlightenment/modules/news/images/categories
+@dirrm lib/enlightenment/modules/news/images/feeds
+@dirrm lib/enlightenment/modules/news/images
+@dirrm lib/enlightenment/modules/news/
+@dirrmtry lib/enlightenment/modules
+@dirrmtry lib/enlightenment