aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Beyer <beyert@cs.ucr.edu>2022-06-27 07:03:15 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2022-06-27 07:04:03 +0000
commitbf58926b4a0215e065e097cd24654587bfae1f19 (patch)
tree7408b8820679052d82b12f14c59673ad7a9bec33
parent68b199480328b8073a1ff97f2b62597010cf8137 (diff)
downloadports-bf58926b4a0215e065e097cd24654587bfae1f19.tar.gz
ports-bf58926b4a0215e065e097cd24654587bfae1f19.zip
Add emulators/libretro-bsnes
Standalone port of bSNES 2014 (performance) to libretro emulator PR: 252190
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/libretro-bsnes/Makefile29
-rw-r--r--emulators/libretro-bsnes/distinfo3
-rw-r--r--emulators/libretro-bsnes/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index ae76495c5847..86243d34875b 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -57,6 +57,7 @@
SUBDIR += lib765
SUBDIR += libc6-shim
SUBDIR += libdsk
+ SUBDIR += libretro-bsnes
SUBDIR += libretro-flycast
SUBDIR += libretro-kronos
SUBDIR += libretro-mame
diff --git a/emulators/libretro-bsnes/Makefile b/emulators/libretro-bsnes/Makefile
new file mode 100644
index 000000000000..c6869f69ddbe
--- /dev/null
+++ b/emulators/libretro-bsnes/Makefile
@@ -0,0 +1,29 @@
+# Created by: Timothy Beyer <beyert@cs.ucr.edu>
+
+PORTNAME= libretro-bsnes
+PORTVERSION= 20211218
+CATEGORIES= emulators games
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= Standalone port of bSNES to libretro
+
+LICENSE= GPLv3
+
+USES= compiler:c++11-lib gmake
+
+USE_GCC= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= libretro
+GH_PROJECT= bsnes-libretro
+GH_TAGNAME= 9549275
+
+USE_LDCONFIG= yes
+
+PLIST_FILES= lib/libretro/bsnes_libretro.so
+
+do-install:
+ @${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro;
+ ${INSTALL_LIB} ${WRKSRC}/bsnes_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro;
+
+.include <bsd.port.mk>
diff --git a/emulators/libretro-bsnes/distinfo b/emulators/libretro-bsnes/distinfo
new file mode 100644
index 000000000000..501e0b5aecec
--- /dev/null
+++ b/emulators/libretro-bsnes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1640163197
+SHA256 (libretro-bsnes-libretro-20211218-9549275_GH0.tar.gz) = 76f5de645b425ddd9c90085fc5d5b9309c378475e964d149aed253569fc8aa76
+SIZE (libretro-bsnes-libretro-20211218-9549275_GH0.tar.gz) = 7281394
diff --git a/emulators/libretro-bsnes/pkg-descr b/emulators/libretro-bsnes/pkg-descr
new file mode 100644
index 000000000000..a567f1cf87df
--- /dev/null
+++ b/emulators/libretro-bsnes/pkg-descr
@@ -0,0 +1,3 @@
+Standalone port of bSNES to libretro.
+
+WWW: https://github.com/libretro/bsnes-libretro