aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-07-24 03:27:08 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-07-24 03:27:08 +0000
commitfaa4dd5e19f317a42b814f73d4af5e1d51b79e77 (patch)
tree0d6185c430276f7c19b84d948595138491f043f4
parentd5df640b1b15af503e7de1c7d02d1ac1642b1858 (diff)
downloadports-faa4dd5e19f317a42b814f73d4af5e1d51b79e77.tar.gz
ports-faa4dd5e19f317a42b814f73d4af5e1d51b79e77.zip
Notes
-rw-r--r--audio/glame/Makefile19
-rw-r--r--audio/glame/distinfo4
-rw-r--r--audio/glame/files/patch-src::hash::glsignal.c14
-rw-r--r--audio/glame/files/patch-swapfile.c11
-rw-r--r--audio/glame/pkg-descr13
-rw-r--r--audio/glame/pkg-plist6
6 files changed, 25 insertions, 42 deletions
diff --git a/audio/glame/Makefile b/audio/glame/Makefile
index 63d48e97abac..163186d17b3f 100644
--- a/audio/glame/Makefile
+++ b/audio/glame/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= glame
-PORTVERSION= 1.0.3
+PORTVERSION= 2.0.1
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,20 +15,25 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A powerful, fast, stable, and easily extensible sound editor for GNOME
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
-LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
- vorbis.3:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
+ mad.2:${PORTSDIR}/audio/libmad \
+ vorbis.3:${PORTSDIR}/audio/libvorbis \
+ guile.15:${PORTSDIR}/lang/guile
USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget libglade
+USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui
+USE_GCC= 3.4
USE_LIBLTDL= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib -lltdl ${PTHREAD_LIBS}" \
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
MAKEINFO="makeinfo --no-split"
INFO= glame glame-dev
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -lltdl
+
post-extract:
@cd ${WRKSRC}/doc && ${RM} -f *.info*
diff --git a/audio/glame/distinfo b/audio/glame/distinfo
index 47e5a4a91c8c..5ccf7cc842a1 100644
--- a/audio/glame/distinfo
+++ b/audio/glame/distinfo
@@ -1,2 +1,2 @@
-MD5 (glame-1.0.3.tar.gz) = 9dc47b94f1d3c64eff36d5e61375ff78
-SIZE (glame-1.0.3.tar.gz) = 1638755
+MD5 (glame-2.0.1.tar.gz) = b18e93e8f5d2ed9cd56c4e8088a58f18
+SIZE (glame-2.0.1.tar.gz) = 1662524
diff --git a/audio/glame/files/patch-src::hash::glsignal.c b/audio/glame/files/patch-src::hash::glsignal.c
deleted file mode 100644
index 89e3f241aa67..000000000000
--- a/audio/glame/files/patch-src::hash::glsignal.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/hash/glsignal.c.orig Sat Oct 23 22:14:22 2004
-+++ src/hash/glsignal.c Sat Dec 11 21:30:33 2004
-@@ -63,7 +63,11 @@
-
- glame_list_foreach(&dest->handlers, glsig_handler_t, list, h) {
- va_list vac;
-+#if defined(__FreeBSD__) && defined(__GNUC__) && (__GNUC__ < 3)
-+ vac = va;
-+#else
- va_copy(vac, va);
-+#endif
- _glsig_handler_exec(h, sig, vac);
- va_end(vac);
- }
diff --git a/audio/glame/files/patch-swapfile.c b/audio/glame/files/patch-swapfile.c
index 97f682f4505d..412fee712593 100644
--- a/audio/glame/files/patch-swapfile.c
+++ b/audio/glame/files/patch-swapfile.c
@@ -1,13 +1,16 @@
---- src/swapfile/swapfile_fs.c.orig Fri Dec 6 07:35:22 2002
-+++ src/swapfile/swapfile_fs.c Fri Dec 6 07:41:02 2002
-@@ -44,6 +44,10 @@
+--- src/swapfile/swapfile_fs.c.orig Sat Oct 23 22:09:29 2004
++++ src/swapfile/swapfile_fs.c Tue Mar 29 23:11:17 2005
+@@ -44,8 +44,12 @@
#define DEBUG 1
#endif
+-#include <sys/stat.h>
+#if __FreeBSD__ >= 5
+#define __BSD_VISIBLE 1
+#endif
+
- #include <sys/stat.h>
#include <sys/types.h>
++#include <sys/stat.h>
#include <pthread.h>
+ #include <fcntl.h>
+ #include <dirent.h>
diff --git a/audio/glame/pkg-descr b/audio/glame/pkg-descr
index ee23caf0f9ef..7675fc8ec19c 100644
--- a/audio/glame/pkg-descr
+++ b/audio/glame/pkg-descr
@@ -2,17 +2,4 @@ GLAME is meant to be the GIMP of audio processing. It is designed to be
a powerful, fast, stable, and easily extensible sound editor for GNOME
desktop.
-Current Status (as of version 0.2.0):
-==========================================
-- usable filternetwork GUI - src/gui/glame
-- usable console UI - src/cglame
-- the glame midlayer which supports
- * plugins
- * scripting (using guile)
-- the filternetwork backend which supports
- * threading, i.e. pipelined processing of all data
- * feedback inside the network does work
- * zero-copy operation inside and between filters
-- the swapfile backing store
-
WWW: http://glame.sourceforge.net/
diff --git a/audio/glame/pkg-plist b/audio/glame/pkg-plist
index a35e355b1728..dc71996c276f 100644
--- a/audio/glame/pkg-plist
+++ b/audio/glame/pkg-plist
@@ -4,6 +4,8 @@ bin/glame-convert.sh
lib/glame/audio_io_esd.so
lib/glame/audio_io_oss.so
lib/glame/debug.so
+lib/glame/file_mp3_out.so
+lib/glame/file_oggvorbis_out.so
lib/glame/mixer.so
lib/glame/normalize.so
lib/glame/resample.so
@@ -36,6 +38,7 @@ share/gnome/glame/pixmaps/output.png
share/gnome/glame/pixmaps/pan.png
share/gnome/glame/pixmaps/ping.png
share/gnome/glame/pixmaps/pipe.png
+share/gnome/glame/pixmaps/play-button.png
share/gnome/glame/pixmaps/play.png
share/gnome/glame/pixmaps/prod.png
share/gnome/glame/pixmaps/pulse.png
@@ -47,6 +50,7 @@ share/gnome/glame/pixmaps/select_all.png
share/gnome/glame/pixmaps/select_none.png
share/gnome/glame/pixmaps/sine.png
share/gnome/glame/pixmaps/statistics.png
+share/gnome/glame/pixmaps/stop-button.png
share/gnome/glame/pixmaps/sum.png
share/gnome/glame/pixmaps/volume_adjust.png
share/gnome/glame/pixmaps/zoom_in.png
@@ -58,10 +62,8 @@ share/gnome/glame/scripts/glame_testsuite.scm
share/gnome/glame/scripts/read_mp3.scm
share/gnome/glame/scripts/resample.scm
share/gnome/glame/scripts/write_mp3.scm
-share/locale/da/LC_MESSAGES/glame.mo
share/locale/de/LC_MESSAGES/glame.mo
share/locale/fr/LC_MESSAGES/glame.mo
-share/locale/it/LC_MESSAGES/glame.mo
@dirrm share/gnome/glame/scripts
@dirrm share/gnome/glame/pixmaps
@dirrm share/gnome/glame