diff options
author | Tobias C. Berner <tcberner@FreeBSD.org> | 2017-06-25 21:07:58 +0000 |
---|---|---|
committer | Tobias C. Berner <tcberner@FreeBSD.org> | 2017-06-25 21:07:58 +0000 |
commit | 5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch) | |
tree | 3291541f3b73432c893dec35f4f23770dd07732a /CHANGES | |
parent | 9c92503171817f96d944009b9ea88d3c083c9a45 (diff) |
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building.
Therefore switch from having the ninja generator opt-in to having it opt-out.
Previously cmake-ports that wanted to use ninja could set
CMAKE_NINJA=yes
now, ports that do not work with ninja can set
cmake:<existing args>,noninja
Note, that needing this should be an exception and most often points to a broken
cmake of the port.
The ports using cmake were modified
* removed USES=gmake, if ninja is used
* removed MAKE_ARGS, if ninja is used
* added the cmake-argument noninja if necessary
PR: 219629
PR: 213331
Exp-run by: antoine
Reviewed by: rakuco
Differential Revision: https://reviews.freebsd.org/D10748
Notes
Notes:
svn path=/head/; revision=444324
Diffstat (limited to 'CHANGES')
-rw-r--r-- | CHANGES | 14 |
1 files changed, 14 insertions, 0 deletions
@@ -10,6 +10,20 @@ in the release notes and/or placed into UPDATING. All ports committers are allowed to commit to this file. +20170625: +AUTHOR: kde@FreeBSD.org + + The default generator for USES=cmake ports has been switched to ninja. + + Previously it was possible to opt-in to using ninja instead of make(1) + by setting CMAKE_NINJA, now ports need to opt-out. + + Ports that do not build with ninja must switch from + USES=cmake:<args> + to + USES=cmake:<args>,noninja + + 20170417: AUTHOR: kwm@FreeBSD.org |