aboutsummaryrefslogtreecommitdiff
path: root/CHANGES
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-08-09 15:44:27 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-08-09 15:44:27 +0000
commit900db324a35a535534c39fc88ba374e4fe6c8d29 (patch)
treeb3bd70d2aa9673b13c4a53db11582d39b1e33eb7 /CHANGES
parentead56eb20ceb8747918e7d8421f12e588d78bb03 (diff)
downloadports-900db324a35a535534c39fc88ba374e4fe6c8d29.tar.gz
ports-900db324a35a535534c39fc88ba374e4fe6c8d29.zip
Convert the Python framework bits to USES=python.
Please use USES=python instead of USE_PYTHON. USE_PYTHON=yes becomes USES=python USE_PYTHON=2.7+ becomes USES=python:2.7+ USE_PYTHON_BUILD=3.3 becomes USES=python:3.3,build ... A new PYTHON_FEATURES variable was added, which enables certain features for a port and replaces some knobs at the same time; PYTHON_FEATURES=distutils replaces USE_PYDISTUTILS PYTHON_FEATURES=autoplist replaces PYDISTUTILS_AUTOPLIST PYTHON_FEATURES=py3kplist replaces PYTHON_PY3K_PLIST_HACK PYTHON_FEATURES=noegginfo replaces PYDISTUTILS_NOEGGINFO PYTHON_FEATURES=concurrent replaces PYTHON_CONCURRENT_INSTALL PYTHON_FEATURES=pythonprefix replaces USE_PYTHON_PREFIX Some knobs have been deprecated and are to be removed in the near future: PYTHON_MASTER_SITES - use MASTER_SITE_PYTHON instead PYTHON_PKGNAMESUFFIX - use PYTHON_PKGNAMEPREFIX instead PYDISTUTILS_INSTALLNOSINGLE - deprecated without replacement Some knobs have been removed completely: PYTHON_MASTER_SITE_SUBDIR PYTHON_DISTNAME PYTHON_WRKSRC Several variables specific to the Python framework are no longer passed to the build environment to avoid polluting dependency builds. PYTHON_VERSION is not passed to .MAKEFLAGS anymore PYTHON_DEFAULT_VERSION, PYTHON_DEFAULT_PORTVERSION and PYTHONBASE are not passed to the make environment anymore The conversion required a couple of ports to be updated to fit the changes and new requirements. Those included "bsd.python.mk" directly or contained checks in places, for which the USES framework would fail to provide correct values. Python modules directly using the upstream Python package (such as py-tkinter or py-sqlite3) were updated to avoid using the now unnecessary and remmoved knobs from "bsd.python.mk". Phabric: D399 exp-run: 167368 192357 PR: 167368 192357 Reviewed by: antoine, wg Exp-run award: antoine With hat: python@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=364450
Diffstat (limited to 'CHANGES')
-rw-r--r--CHANGES23
1 files changed, 23 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index c363551a70b8..43e177c30ff8 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,29 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20140809:
+AUTHOR: mva@FreeBSD.org
+
+ The Python language bits of the poorts framework have been converted
+ to USES. Instead of USE_PYTHON, please use USES=python instead.
+
+ USE_PYTHON=yes becomes USES=python
+ USE_PYTHON=2.7+ becomes USES=python:2.7+
+ USE_PYTHON_BUILD=3.3 becomes USES=python:3.3,build
+ ...
+
+ Additionally, several Python specific feeatures have been converted
+ to USES-inspired PYTHON_FEATURES=<featureA>,<featureB>.
+
+ USE_PYDISTUTILS becomes PYTHON_FEATURES=distutils
+ PYDISTUTILS_AUTOPLIST becomes PYTHON_FEATURES=autoplist
+ ...
+
+ Please read the header comments of Uses/python.mk for more details
+ about the new and changed bits and pieces. You will find a list of
+ deprecated variables and how to replace them in your own ports at
+ the end of the header comment.
+
20140715:
AUTHOR: bapt@FreeBSD.org