aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2006-01-21 17:37:14 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2006-01-21 17:37:14 +0000
commit01c588a6357d8452a3e0af157e9c1250c067db2f (patch)
treefb26bf418ea8791ab4d308a7931c623124611c3c /Makefile
parentf484c99df79f169bf954fc4b0ed83e59279a596a (diff)
downloadports-01c588a6357d8452a3e0af157e9c1250c067db2f.tar.gz
ports-01c588a6357d8452a3e0af157e9c1250c067db2f.zip
Notes
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 40b3002fa864..bf49cc385a0a 100644
--- a/Makefile
+++ b/Makefile
@@ -134,11 +134,18 @@ print-index: ${.CURDIR}/${INDEXFILE}
CVS?= cvs
SUP?= cvsup
+PORTSNAP?= portsnap
+PORTSNAP_FLAGS?= -p ${.CURDIR}
.if defined(SUPHOST)
SUPFLAGS+= -h ${SUPHOST}
.endif
update:
-.if defined(SUP_UPDATE) && defined(PORTSSUPFILE)
+.if defined(PORTSNAP_UPDATE)
+ @echo "--------------------------------------------------------------"
+ @echo ">>> Running ${PORTSNAP}"
+ @echo "--------------------------------------------------------------"
+ @${PORTSNAP} ${PORTSNAP_FLAGS} fetch update
+.elif defined(SUP_UPDATE) && defined(PORTSSUPFILE)
@echo "--------------------------------------------------------------"
@echo ">>> Running ${SUP}"
@echo "--------------------------------------------------------------"
@@ -152,5 +159,5 @@ update:
@${ECHO_MSG} "Error: Please define PORTSSUPFILE before doing make update."
@exit 1
.else
- @${ECHO_MSG} "Error: Please define either SUP_UPDATE or CVS_UPDATE first."
+ @${ECHO_MSG} "Error: Please define either PORTSNAP_UPDATE, SUP_UPDATE, or CVS_UPDATE first."
.endif