aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-07-23 09:36:55 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-07-23 09:36:55 +0000
commita163079f0d26f857c023dc7f21ed9acaeeb8590c (patch)
tree76e97537a2030bd95501b69d988c7beee0db6f72 /Makefile
parentcd7e9ffb8c14a1b7981b7087c7317d6978df808a (diff)
downloadports-a163079f0d26f857c023dc7f21ed9acaeeb8590c.tar.gz
ports-a163079f0d26f857c023dc7f21ed9acaeeb8590c.zip
Notes
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 0a4ac4c783c7..f3a07fac3df7 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-# $Id: Makefile,v 1.48 1999/06/04 17:30:31 billf Exp $
+# $Id: Makefile,v 1.49 1999/06/26 22:29:57 asami Exp $
#
SUBDIR += archivers
@@ -58,6 +58,12 @@ ${.CURDIR}/INDEX:
@echo -n "Generating INDEX - please wait.."
@make describe ECHO_MSG="echo > /dev/null" | \
perl ${.CURDIR}/Tools/make_index > ${.CURDIR}/INDEX
+.if !defined(INDEX_NOSORT)
+ @sed -e 's./..g' ${.CURDIR}/INDEX | \
+ sort -t '|' +1 -2 | \
+ sed -e 's../.g' > ${.CURDIR}/INDEX.tmp
+ @mv -f ${.CURDIR}/INDEX.tmp ${.CURDIR}/INDEX
+.endif
@echo " Done."
print-index: ${.CURDIR}/INDEX