diff options
author | Satoshi Asami <asami@FreeBSD.org> | 1999-01-22 10:32:32 +0000 |
---|---|---|
committer | Satoshi Asami <asami@FreeBSD.org> | 1999-01-22 10:32:32 +0000 |
commit | 075386ef4f0a1222df94ea27d3567bccc2fe6e52 (patch) | |
tree | 68a243172517481f162722a8e5c14abf961ebdd3 /Makefile | |
parent | b568349be8f25d340bfacc8c1a4d3c14d664330b (diff) | |
download | ports-075386ef4f0a1222df94ea27d3567bccc2fe6e52.tar.gz ports-075386ef4f0a1222df94ea27d3567bccc2fe6e52.zip |
Notes
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -1,4 +1,4 @@ -# $Id: Makefile,v 1.43 1999/01/09 08:52:08 asami Exp $ +# $Id: Makefile,v 1.44 1999/01/13 04:08:05 jkh Exp $ # SUBDIR += archivers @@ -69,4 +69,7 @@ search: ${.CURDIR}/INDEX .endif parallel: ${.CURDIR}/INDEX - @sed -e 's/|/.tgz|/' ${.CURDIR}/INDEX | awk -F '|' '{me=$$1; here=$$2; bdep=$$8; rdep=$$9; if (bdep != "") { gsub("$$", ".tgz", bdep); gsub(" ", ".tgz ", bdep); } if (rdep != "") { gsub("$$", ".tgz", rdep); gsub(" ", ".tgz ", rdep); } print "all:: " me; print me ": " bdep " " rdep; printf("\t@/a/asami/portbuild/pdispatch /a/asami/portbuild/portbuild %s %s", me, here); if (bdep != "") printf(" %s", bdep); if (rdep != "") printf(" %s", rdep); printf("\n")}' +.for dir in ${SUBDIR} + @echo "all:: ${dir}-all" +.endfor + @sed -e 's/|/.tgz|/' ${.CURDIR}/INDEX | awk -F '|' '{me=$$1; here=$$2; bdep=$$8; rdep=$$9; split(here, tmp, "/"); if (bdep != "") { gsub("$$", ".tgz", bdep); gsub(" ", ".tgz ", bdep); } if (rdep != "") { gsub("$$", ".tgz", rdep); gsub(" ", ".tgz ", rdep); } print tmp[4] "-all:: " me; print me ": " bdep " " rdep; printf("\t@/a/asami/portbuild/scripts/pdispatch /a/asami/portbuild/scripts/portbuild %s %s", me, here); if (bdep != "") printf(" %s", bdep); if (rdep != "") printf(" %s", rdep); printf("\n")}' |