aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2004-11-16 09:12:34 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2004-11-16 09:12:34 +0000
commit16726a6a5b65667339ec74726b05bd7e7af6cfe6 (patch)
tree6e828137702cb38f31d5a5c1ce50a5bbf9b0c4a7 /Makefile
parentd1140c6c156e4ba6faa6e4bfdffa386a7d6c79bf (diff)
downloadports-16726a6a5b65667339ec74726b05bd7e7af6cfe6.tar.gz
ports-16726a6a5b65667339ec74726b05bd7e7af6cfe6.zip
Allow to override fetch option by $FETCHINDEX variable.
Approved by: portmgr (krion)
Notes
Notes: svn path=/head/; revision=121741
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 534b99a04731..e8c287d86784 100644
--- a/Makefile
+++ b/Makefile
@@ -71,8 +71,9 @@ index:
@cd ${.CURDIR} && make ${.CURDIR}/${INDEXFILE}
fetchindex:
- @cd ${.CURDIR} && fetch -am http://www.FreeBSD.org/ports/${INDEXFILE}.bz2 && bunzip2 -f ${INDEXFILE}.bz2 && chmod a+r ${INDEXFILE}
+ @cd ${.CURDIR} && ${FETCHINDEX} http://www.FreeBSD.org/ports/${INDEXFILE}.bz2 && bunzip2 -f ${INDEXFILE}.bz2 && chmod a+r ${INDEXFILE}
+FETCHINDEX?= fetch -am
INDEX_JOBS?= 2
.if !defined(INDEX_VERBOSE)