aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:07:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:07:24 +0000
commit0de3ff661acec63625e5bf537d3305273b9edd3e (patch)
tree61c495663ecd565ff7f7dad86105f6901a721a24 /Makefile
parentf4ec9c6ead3b8e182d8d38b1a298bf069656bb6c (diff)
downloadports-0de3ff661acec63625e5bf537d3305273b9edd3e.tar.gz
ports-0de3ff661acec63625e5bf537d3305273b9edd3e.zip
bsd.port.mk
[1] Remove DEPENDS [2] Add a new pkg-plist keyword @stopdaemon [3] Provide rc.subr script suffix as RC_SUBR_SUFFIX [4] Add USE_CDRTOOLS to abstract dependency on sysutils/cdrtool[-cjk] [5] Add DOS2UNIX_REGEX, allowing to pass a filename regex to CRLF replacement routine [6] Support partially translated manpages in MAN* variables [7] Fix USE_LDCONFIG on ports with @cwd in pkg-plist [8] Remove support for XFree86 3.X [9] Add user settable WITH_DEBUG flag that turns on -g in CFLAGS and resets STRIP [9] Fix `make install' to refuse overwriting of older version of the port [10] New category ports-mgmt [11] New category gnustep [12] Removed category picobsd bsd.java.mk [13] Remove deprecated syntax bsd.tcl.mk [14] Provide TCL_VER when USE_TK[_BUILD] is defined. Fixes cad/netgen ports/Makefile [15] Make csup default `make update' method on FreeBSD 6.2 and up PR: ports/99742 [1], ports/93373 [2], ports/100915 [3], ports/105161 [4], ports/106029 [5], ports/106252 [6], ports/106235 [7], ports/100939 [9], ports/97507 [10], ports/103931 [11], ports/106921 [12], ports/104136 [13], ports/105215 [15] Submitted by: sem [1] [2], Matthias Andree <matthias.andree@gmx.de> [3], nork [4], pav [5] [7] [14], Nick Barkas <snb@threerings.net> [6], flz [8], gabor [9], shaun [10], erwin [12], hq [13], Gurkan Sengun <gurkan@linuks.mine.nu> [11]
Notes
Notes: svn path=/head/; revision=183768
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 3f52d8b7dd4a..f0430506a685 100644
--- a/Makefile
+++ b/Makefile
@@ -139,7 +139,11 @@ print-index: ${INDEXDIR}/${INDEXFILE}
@awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\nE-deps:\t%s\nP-deps:\t%s\nF-deps:\t%s\nWWW:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9, $$11, $$12, $$13, $$10); }' < ${INDEXDIR}/${INDEXFILE}
CVS?= cvs
+.if ${OSVERSION} >= 601101
+SUP?= csup
+.else
SUP?= cvsup
+.endif
PORTSNAP?= portsnap
PORTSNAP_FLAGS?= -p ${.CURDIR}
.if defined(SUPHOST)