aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-06-15 22:47:10 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-06-15 22:47:10 +0000
commit0b2a22b77cefd9411194aa9973e323a9530e2385 (patch)
tree4cdfe0fd3981178f3816dd4ed37423707ebce574 /Makefile
parent5d4d1b66042c9c736004f20c9f55d14458c4d55e (diff)
downloadports-0b2a22b77cefd9411194aa9973e323a9530e2385.tar.gz
ports-0b2a22b77cefd9411194aa9973e323a9530e2385.zip
Add a mechanism to allow updating the ports tree with rsync
PR: 171681 Submitted by: cyberleo@cyberleo.net
Notes
Notes: svn path=/head/; revision=357936
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 34977ee79625..8b8f9d6f2395 100644
--- a/Makefile
+++ b/Makefile
@@ -162,6 +162,7 @@ print-index: ${INDEXDIR}/${INDEXFILE}
GIT?= git
SVN?= svn
+RSYNC?= rsync
PORTSNAP?= portsnap
PORTSNAP_FLAGS?= -p ${.CURDIR}
.if !target(update)
@@ -176,6 +177,11 @@ update:
@echo ">>> Updating ${.CURDIR} from git+svn repository"
@echo "--------------------------------------------------------------"
cd ${.CURDIR}; ${GIT} svn rebase
+.elif defined(RSYNC_UPDATE) && defined(PORTS_RSYNC_SOURCE)
+ @echo "--------------------------------------------------------------"
+ @echo ">>> Updating with ${RSYNC} from ${PORTS_RSYNC_SOURCE}"
+ @echo "--------------------------------------------------------------"
+ @${RSYNC} ${RSYNC_FLAGS} ${PORTS_RSYNC_SOURCE}/ ${.CURDIR}/
.else
@echo "--------------------------------------------------------------"
@echo ">>> Running ${PORTSNAP}"