diff options
author | Beat Gaetzi <beat@FreeBSD.org> | 2012-07-15 18:23:24 +0000 |
---|---|---|
committer | Beat Gaetzi <beat@FreeBSD.org> | 2012-07-15 18:23:24 +0000 |
commit | a0e668c21238e5123d220914db4adb000a0fa275 (patch) | |
tree | 9dfd6b18c81fd4b26f9036a3497158f0e374ef1f /Makefile | |
parent | c8e601d4edd645bc6824e08e377fcd180f84ef8d (diff) |
Notes
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 8 |
1 files changed, 8 insertions, 0 deletions
@@ -152,6 +152,7 @@ print-index: ${INDEXDIR}/${INDEXFILE} @awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\nE-deps:\t%s\nP-deps:\t%s\nF-deps:\t%s\nWWW:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9, $$11, $$12, $$13, $$10); }' < ${INDEXDIR}/${INDEXFILE} CVS?= cvs +SVN?= svn SUP?= csup PORTSNAP?= portsnap PORTSNAP_FLAGS?= -p ${.CURDIR} @@ -171,6 +172,12 @@ update: @echo "--------------------------------------------------------------" cd ${.CURDIR}; ${CVS} -R -q update -A -P -d -I! .else +.if exists(${.CURDIR}/.svn) + @echo "--------------------------------------------------------------" + @echo ">>> Updating ${.CURDIR} from svn repository" + @echo "--------------------------------------------------------------" + cd ${.CURDIR}; ${SVN} -q update +.else @echo "--------------------------------------------------------------" @echo ">>> Running ${PORTSNAP}" @echo "--------------------------------------------------------------" @@ -186,3 +193,4 @@ update: .endif .endif .endif +.endif |