diff options
author | Mark Linimon <linimon@FreeBSD.org> | 2006-01-28 02:11:35 +0000 |
---|---|---|
committer | Mark Linimon <linimon@FreeBSD.org> | 2006-01-28 02:11:35 +0000 |
commit | b09666fc1e84f3c48ffd364896f780150a2cf5a9 (patch) | |
tree | c998550baecf34be07870269231bbbcbca9ae8c8 /Makefile | |
parent | 59da8c223b9e2c7be998c21dd9ea8fcbb6977dc7 (diff) |
- Fix possibility of "infinite make fork" when "Registering install for ..."
EMACS ports. [1]
- Allow building a port as root using an NFS-mounted /usr/ports if the
server maps root to a UID other than root. [2]
- Make 'BROKEN' and 'IGNORED' ports exit their "make install" with a fail
status rather than success. [3]
- Improve behavior when dealing with versioned dependencies. [4]
- Fix false positives in check-conflicts target. [5]
- Remove obsolete bzip2 code. [6]
- Add physical category net-p2p. [7]
- Don't fetch INDEXFILE if not necessary; respect FETCH_ENV. [8], [11]
- INDEX can now be moved outside of ports tree. [9]
- Add ghostscript-gpl. [10]
- Remove obsolete USE_MESA. [12]
- Force pkg_install tools from ports on FreeBSD 4.10 and older. [13]
- Document ALWAYS_KEEP_DISTFILES. [14]
- Remove USE_REINPLACE from bsd.port.mk USE_DOS2UNIX patch. [15]
PR: ports/37596 [1], ports/57259 [2], ports/63216 [3],
ports/89448 [4], ports/89710 [5], ports/88996 [6],
ports/89260 [7], ports/89363 [8], ports/89809 [9],
ports/89853 [10], ports/91086 [11], ports/91710 [12],
ports/91727 [13], ports/92111 [14], ports/92124 [15]
Submitted by: Jay Sachs <jay at eziba dot com> [1], sem [1, 3, 8, 12],
Andrew Heybey <ath at niksun dot com> [2], Jamie Jones
<jamie at thompson dot bishopston dot net>, tobez [4], Mark
Andrews <Mark_Andrews at isc dot org> [5], edwin [6, 11, 15],
pav [7, 13], Peter Jeremy <PeterJeremy at optushome dot com
dot au> [9], Ulrich Spoerlein <q at galgenberg dot net> [10],
netchild [11], erwin [14]
Reviewed by: kris, clement (partially)
Notes
Notes:
svn path=/head/; revision=154626
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 28 |
1 files changed, 17 insertions, 11 deletions
@@ -39,6 +39,7 @@ SUBDIR += multimedia SUBDIR += net SUBDIR += net-im SUBDIR += net-mgmt +SUBDIR += net-p2p SUBDIR += news SUBDIR += palm SUBDIR += polish @@ -67,14 +68,19 @@ PORTSTOP= yes .include <bsd.port.subdir.mk> index: - @rm -f ${.CURDIR}/${INDEXFILE} - @cd ${.CURDIR} && make ${.CURDIR}/${INDEXFILE} + @rm -f ${INDEXDIR}/${INDEXFILE} + @cd ${.CURDIR} && make ${INDEXDIR}/${INDEXFILE} -fetchindex: - @cd ${.CURDIR} && ${FETCHINDEX} ${MASTER_SITE_INDEX}/${INDEXFILE}.bz2 && bunzip2 -f ${INDEXFILE}.bz2 && chmod a+r ${INDEXFILE} +fetchindex: ${INDEXDIR}/{INDEXFILE}.bz2 + @bunzip2 < ${INDEXDIR}/${INDEXFILE}.bz2 > ${INDEXDIR}/${INDEXFILE} && \ + chmod a+r ${INDEXDIR}/${INDEXFILE} + +${INDEXDIR}/{INDEXFILE}.bz2: .PHONY + @${FETCHINDEX} -o ${INDEXDIR}/${INDEXFILE}.bz2 ${MASTER_SITE_INDEX}${INDEXFILE}.bz2 MASTER_SITE_INDEX?= http://www.FreeBSD.org/ports/ -FETCHINDEX?= fetch -am +SETENV?= /usr/bin/env +FETCHINDEX?= ${SETENV} ${FETCH_ENV} fetch -am INDEX_JOBS?= 2 .if !defined(INDEX_VERBOSE) @@ -85,7 +91,7 @@ INDEX_ECHO_MSG= echo 1>&2 INDEX_ECHO_1ST= echo .endif -${.CURDIR}/${INDEXFILE}: +${INDEXDIR}/${INDEXFILE}: @${INDEX_ECHO_1ST} "Generating ${INDEXFILE} - please wait.."; \ if [ "${INDEX_PRISTINE}" != "" ]; then \ export LOCALBASE=/nonexistentlocal; \ @@ -119,18 +125,18 @@ ${.CURDIR}/${INDEXFILE}: cat $${tmpdir}/${INDEXFILE}.desc.* | perl ${.CURDIR}/Tools/make_index | \ sed -e 's/ */ /g' -e 's/| */|/g' -e 's/ *|/|/g' -e 's./..g' | \ sort -t '|' +1 -2 | \ - sed -e 's../.g' > ${.CURDIR}/${INDEXFILE}.tmp; \ + sed -e 's../.g' > ${INDEXDIR}/${INDEXFILE}.tmp; \ if [ "${INDEX_PRISTINE}" != "" ]; then \ sed -e "s,$${LOCALBASE},/usr/local," -e "s,$${X11BASE},/usr/X11R6," \ - ${.CURDIR}/${INDEXFILE}.tmp > ${.CURDIR}/${INDEXFILE}; \ + ${INDEXDIR}/${INDEXFILE}.tmp > ${INDEXDIR}/${INDEXFILE}; \ else \ - mv ${.CURDIR}/${INDEXFILE}.tmp ${.CURDIR}/${INDEXFILE}; \ + mv ${INDEXDIR}/${INDEXFILE}.tmp ${INDEXDIR}/${INDEXFILE}; \ fi; \ rm -rf $${tmpdir}; \ echo " Done." -print-index: ${.CURDIR}/${INDEXFILE} - @awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\nE-deps:\t%s\nP-deps:\t%s\nF-deps:\t%s\nWWW:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9, $$11, $$12, $$13, $$10); }' < ${.CURDIR}/${INDEXFILE} +print-index: ${INDEXDIR}/${INDEXFILE} + @awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\nE-deps:\t%s\nP-deps:\t%s\nF-deps:\t%s\nWWW:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9, $$11, $$12, $$13, $$10); }' < ${INDEXDIR}/${INDEXFILE} CVS?= cvs SUP?= cvsup |