diff options
author | Beat Gaetzi <beat@FreeBSD.org> | 2012-08-02 12:19:35 +0000 |
---|---|---|
committer | Beat Gaetzi <beat@FreeBSD.org> | 2012-08-02 12:19:35 +0000 |
commit | b0be23e64dee1b1fcd03dea97afa514586bd9933 (patch) | |
tree | 7549fe0d18694a8ce95e233da39d0e08bc297569 /Makefile | |
parent | 344b32ccd9f4853dff7b8d1bbcb191bf46c6f5ca (diff) |
- Sync update target with src/ [1]
- Add 'git svn rebase' command to update target [2]
PR: ports/169970 [1], ports/169983 [2]
Submitted by: avilla@ [1], clutton <mbsd AT isgroup.com.ua> [2]
Tested by: exp-run on pointyhat
Notes
Notes:
svn path=/head/; revision=301859
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 16 |
1 files changed, 10 insertions, 6 deletions
@@ -152,6 +152,7 @@ print-index: ${INDEXDIR}/${INDEXFILE} @awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\nE-deps:\t%s\nP-deps:\t%s\nF-deps:\t%s\nWWW:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9, $$11, $$12, $$13, $$10); }' < ${INDEXDIR}/${INDEXFILE} CVS?= cvs +GIT?= git SVN?= svn SUP?= csup PORTSNAP?= portsnap @@ -168,15 +169,19 @@ update: @${SUP} ${SUPFLAGS} ${PORTSSUPFILE} .elif defined(CVS_UPDATE) @echo "--------------------------------------------------------------" - @echo ">>> Updating ${.CURDIR} from cvs repository" ${CVSROOT} + @echo ">>> Updating ${.CURDIR} from CVS repository" ${CVSROOT} @echo "--------------------------------------------------------------" cd ${.CURDIR}; ${CVS} -R -q update -A -P -d -I! -.else -.if exists(${.CURDIR}/.svn) +.elif exists(${.CURDIR}/.svn) + @echo "--------------------------------------------------------------" + @echo ">>> Updating ${.CURDIR} using Subversion" @echo "--------------------------------------------------------------" - @echo ">>> Updating ${.CURDIR} from svn repository" + cd ${.CURDIR}; ${SVN} update +.elif exists(${.CURDIR}/.git) @echo "--------------------------------------------------------------" - cd ${.CURDIR}; ${SVN} -q update + @echo ">>> Updating ${.CURDIR} from git+svn repository" + @echo "--------------------------------------------------------------" + cd ${.CURDIR}; ${GIT} ${SVN} rebase .else @echo "--------------------------------------------------------------" @echo ">>> Running ${PORTSNAP}" @@ -193,4 +198,3 @@ update: .endif .endif .endif -.endif |