aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/gecko.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-08-04 09:11:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-08-04 09:11:25 +0000
commitf92079c61ea2516fd5b1514bae10c743ba63b699 (patch)
tree1e9acf477fa72cf7c888cc484c96bd4f207a487a /Mk/Uses/gecko.mk
parent397fa72062e7ed8fab7c8a395a1f9475d9723709 (diff)
Notes
Diffstat (limited to 'Mk/Uses/gecko.mk')
-rw-r--r--Mk/Uses/gecko.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index 60261709938c..92df7029c7b2 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -39,12 +39,12 @@ RUN_DEPENDS+= libxul>=24:${PORTSDIR}/www/libxul
.elif ${_GECKO_ARGS:Mfirefox}
_GECKO_DEFAULT_VERSION= 24
-_GECKO_VERSIONS= 24 30
+_GECKO_VERSIONS= 24 31
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
24_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
-30_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
+31_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${LOCALBASE}/bin/firefox --version 2>/dev/null
@@ -67,8 +67,8 @@ _GECKO_INSTALLED_VER:= ${_GECKO_INSTALLED_VER:M[0-9]*:C/[0-9].([0-9][0-9]).*/\1/
.elif ${_GECKO_ARGS:Mthunderbird}
-_GECKO_DEFAULT_VERSION= 24
-_GECKO_VERSIONS= 24
+_GECKO_DEFAULT_VERSION= 31
+_GECKO_VERSIONS= 31
_GECKO_TYPE= thunderbird
.if exists(${LOCALBASE}/bin/thunderbird)
@@ -77,7 +77,7 @@ _GECKO_INSTALLED_VER:= ${_GECKO_INSTALLED_VER:M[0-9][0-9]*:C/([0-9][0-9]).*/\1/g
.endif
# Dependence lines for different Thunderbird versions
-24_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird
+31_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird
.else
IGNORE= Unknown type of gecko dependency you may specify either libxul, firefox, seamonkey or thunderbird