aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/gecko.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-10-14 16:49:35 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-10-14 16:49:35 +0000
commit869e1f27d0cd912f612cd1af8dd5491749901f80 (patch)
tree253c001da30db94087f88bf237955915bfb0f012 /Mk/Uses/gecko.mk
parent41d6fa567f5fdfc4017313246f4332af3ad716ef (diff)
downloadports-869e1f27d0cd912f612cd1af8dd5491749901f80.tar.gz
ports-869e1f27d0cd912f612cd1af8dd5491749901f80.zip
Notes
Diffstat (limited to 'Mk/Uses/gecko.mk')
-rw-r--r--Mk/Uses/gecko.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index 0902f78c8a08..bb3d68dc5b8c 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -31,8 +31,8 @@ GECKO_CONFING?= ${LOCALBASE}/bin/${GECKO}-config
XPIDL?= ${LOCALBASE}/lib/${GECKO}/xpidl
XPIDL_INCL?= `${GECKO_CONFIG} --idlflags`
-BUILD_DEPENDS+= libxul>=38:${PORTSDIR}/www/libxul
-RUN_DEPENDS+= libxul>=38:${PORTSDIR}/www/libxul
+BUILD_DEPENDS+= libxul>=38:www/libxul
+RUN_DEPENDS+= libxul>=38:www/libxul
.elif ${gecko_ARGS:Mfirefox}
@@ -41,8 +41,8 @@ _GECKO_VERSIONS= 38 41
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
-38_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
-41_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
+38_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox-esr
+41_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${LOCALBASE}/bin/firefox --version 2>/dev/null
@@ -61,7 +61,7 @@ _GECKO_INSTALLED_VER:= ${_GECKO_INSTALLED_VER:M[0-9]*:C/[0-9].([0-9][0-9]).*/\1/
.endif
# Dependence lines for different Seamonkey versions
-33_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey:${PORTSDIR}/www/seamonkey
+33_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey:www/seamonkey
.elif ${gecko_ARGS:Mthunderbird}
@@ -75,7 +75,7 @@ _GECKO_INSTALLED_VER:= ${_GECKO_INSTALLED_VER:M[0-9][0-9]*:C/([0-9][0-9]).*/\1/g
.endif
# Dependence lines for different Thunderbird versions
-38_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird
+38_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:mail/thunderbird
.else
IGNORE= Unknown type of gecko dependency you may specify either libxul, firefox, seamonkey or thunderbird