aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/localbase.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-07-19 14:36:00 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-07-19 14:36:00 +0000
commit81471a0b2a688eaa10b976b1e7028d5bae6a62fe (patch)
treef169cf3f82bb036a610b94fc037cf9a640b24317 /Mk/Uses/localbase.mk
parent8088e0cda1ff0aa065274972fcfc56c3d90cab3a (diff)
downloadports-81471a0b2a688eaa10b976b1e7028d5bae6a62fe.tar.gz
ports-81471a0b2a688eaa10b976b1e7028d5bae6a62fe.zip
Notes
Diffstat (limited to 'Mk/Uses/localbase.mk')
-rw-r--r--Mk/Uses/localbase.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/Mk/Uses/localbase.mk b/Mk/Uses/localbase.mk
new file mode 100644
index 000000000000..044cfcd11faa
--- /dev/null
+++ b/Mk/Uses/localbase.mk
@@ -0,0 +1,18 @@
+# $FreeBSD$
+#
+# handle enforcing localbase in path
+#
+# Feature: localbase
+# Usage: USES=localbase
+# Valid ARGS: none
+#
+# MAINTAINER: portmgr@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_LOCALBASE_MK)
+_INCLUDE_USES_LOCALBASE_MK= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}include
+LDFLAGS+= -L${LOCALBASE}/lib
+.endif