aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/perl5.mk
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2016-12-31 16:50:58 +0000
committerRene Ladan <rene@FreeBSD.org>2016-12-31 16:50:58 +0000
commit5b8a302787b27177ab5d74bd2882ef88dbaa1563 (patch)
tree4f131ef8b27a2d2a29a870d7e85427744bd157f5 /Mk/Uses/perl5.mk
parent166f200fa2a8091796526ca5305caf9bd53ca76e (diff)
downloadports-5b8a302787b27177ab5d74bd2882ef88dbaa1563.tar.gz
ports-5b8a302787b27177ab5d74bd2882ef88dbaa1563.zip
Notes
Diffstat (limited to 'Mk/Uses/perl5.mk')
-rw-r--r--Mk/Uses/perl5.mk10
1 files changed, 3 insertions, 7 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index ff736c41768f..fb885b6521dc 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -20,7 +20,7 @@
# PERL_ARCH - Directory name of architecture dependent libraries
# (value: mach).
# PERL_PORT - Name of the perl port that is installed
-# (for example: perl5.18)
+# (for example: perl5.24)
# SITE_PERL - Directory name where site specific perl packages go.
# This value is added to PLIST_SUB.
# SITE_ARCH - Directory name where arch site specific perl packages go.
@@ -51,9 +51,7 @@ THIS_IS_OLD_PERL= yes
# end of remove
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
-.if ${PERL5_DEFAULT} == 5.18
-.include "${PORTSDIR}/lang/perl5.18/version.mk"
-.elif ${PERL5_DEFAULT} == 5.20
+.if ${PERL5_DEFAULT} == 5.20
.include "${PORTSDIR}/lang/perl5.20/version.mk"
.elif ${PERL5_DEFAULT} == 5.22
.include "${PORTSDIR}/lang/perl5.22/version.mk"
@@ -97,10 +95,8 @@ PERL_ARCH?= mach
PERL_PORT?= perl5.24
.elif ${PERL_LEVEL} >= 502200
PERL_PORT?= perl5.22
-.elif ${PERL_LEVEL} >= 502000
+.else # ${PERL_LEVEL} < 502200
PERL_PORT?= perl5.20
-.else # ${PERL_LEVEL} < 502000
-PERL_PORT?= perl5.18
.endif
SITE_PERL_REL?= lib/perl5/site_perl