aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/perl5.mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-06-10 12:14:12 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-06-10 12:14:12 +0000
commit61de712f4609a18a2988695e252651c69d10cafd (patch)
treeaeafd6b72a8d3be86af00681d166956acc8e815f /Mk/Uses/perl5.mk
parentff48c35ae03604b3cb492efdaa77937635e36375 (diff)
downloadports-61de712f4609a18a2988695e252651c69d10cafd.tar.gz
ports-61de712f4609a18a2988695e252651c69d10cafd.zip
Notes
Diffstat (limited to 'Mk/Uses/perl5.mk')
-rw-r--r--Mk/Uses/perl5.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index a284c68e08ff..7f203804ee35 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -264,9 +264,11 @@ fix-packlist::
-@[ -d ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/auto ] && ${FIND} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/auto -name .packlist -exec ${SED} -i '' 's|^${STAGEDIR}||' '{}' \;
.endif
-.if ${PERL_LEVEL} >= 502000
-fix-plist-perl:
- -@${REINPLACE_CMD} '/\.bs$$/d' ${TMPPLIST}
+# Starting with perl 5.20, the empty bootstrap files are not installed any
+# more. As we don't need them anyway, remove it altogether.
+.if ${PERL_LEVEL} < 502000
+fix-perl-bs:
+ -@${FIND} ${STAGEDIR} -name '*.bs' -size 0 -delete
.endif
.if !target(regression-test)