aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.autotools.mk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-04-05 20:36:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-04-05 20:36:46 +0000
commite42a337bd9eefe2e8a0fd9341f1bd75f3f42b807 (patch)
treee041e4d4600b7c1fa87c8d8cba8b8a81ce1389b3 /Mk/bsd.autotools.mk
parentc41ff2d2dfaf430b8b746f79e524ce47990e6e83 (diff)
Notes
Diffstat (limited to 'Mk/bsd.autotools.mk')
-rw-r--r--Mk/bsd.autotools.mk21
1 files changed, 18 insertions, 3 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 6109b914c179..20daa8684f83 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -182,6 +182,11 @@ BUILD_DEPENDS+= ${AUTOCONF_DEPENDS}
LIB_DEPENDS+= ltdl.7:${PORTSDIR}/devel/libltdl22
.endif
+.if defined(AUTOTOOL_libtoolize)
+AUTOTOOL_libtoolize_env= ${AUTOTOOL_libtoolize}
+GNU_CONFIGURE?= yes
+.endif
+
.if defined(AUTOTOOL_libtool)
GNU_CONFIGURE?= YES
AUTOTOOL_libtool_env= ${AUTOTOOL_libtool}
@@ -231,7 +236,7 @@ AUTOTOOLS_ENV+= ${AUTOTOOLS_VARS}
CONFIGURE_ENV+= ${AUTOTOOLS_VARS}
MAKE_ENV+= ${AUTOTOOLS_VARS}
SCRIPTS_ENV+= ${AUTOTOOLS_VARS}
-. for item in automake aclocal autoconf autoheader libtool
+. for item in automake aclocal autoconf autoheader libtool libtoolize
. if defined(AUTOTOOL_${item}_env)
${item:U}_ENV+= ${AUTOTOOLS_VARS}
. endif
@@ -250,10 +255,10 @@ ${item:U}_ENV+= ${AUTOTOOLS_VARS}
# the order of autotools running.
.if !target(run-autotools)
-.ORDER: run-autotools run-autotools-aclocal patch-autotools run-autotools-autoheader run-autotools-autoconf run-autotools-automake
+.ORDER: run-autotools run-autotools-aclocal patch-autotools run-autotools-autoheader run-autotools-libtoolize run-autotools-autoconf run-autotools-automake
run-autotools:: run-autotools-aclocal patch-autotools run-autotools-autoheader \
- run-autotools-autoconf run-autotools-automake
+ run-autotools-libtoolize run-autotools-autoconf run-autotools-automake
.endif
.if !target(run-autotools-aclocal)
@@ -266,6 +271,16 @@ run-autotools-aclocal:
. endif
.endif
+.if !target(run-autotools-libtoolize)
+run-autotools-libtoolize:
+. if defined(AUTOTOOL_libtoolize)
+ @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE} \
+ ${LIBTOOLIZE_ARGS})
+. else
+ @${DO_NADA}
+. endif
+.endif
+
.if !target(run-autotools-automake)
run-autotools-automake:
. if defined(AUTOTOOL_automake)