aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.cmake.mk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-30 19:25:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-30 19:25:22 +0000
commit18506f2253fd770f2bee243be89814d057720e8c (patch)
tree643906831ff3d66835af05496c0cda7fda4e3d87 /Mk/bsd.cmake.mk
parentfd2b9aecd1349ad18855f7903a169092e674b3ce (diff)
downloadports-18506f2253fd770f2bee243be89814d057720e8c.tar.gz
ports-18506f2253fd770f2bee243be89814d057720e8c.zip
Notes
Diffstat (limited to 'Mk/bsd.cmake.mk')
-rw-r--r--Mk/bsd.cmake.mk15
1 files changed, 6 insertions, 9 deletions
diff --git a/Mk/bsd.cmake.mk b/Mk/bsd.cmake.mk
index d663c5bd67d5..812642a27374 100644
--- a/Mk/bsd.cmake.mk
+++ b/Mk/bsd.cmake.mk
@@ -7,11 +7,9 @@
# Default: ${CONFIGURE_ENV}
# CMAKE_ARGS - Arguments passed to cmake
# Default: see below
-# CMAKE_USE_PTHREAD - Instruct cmake to use pthreads when
+# CMAKE_USE_PTHREAD - Instruct cmake to use pthreads when
# compiling/linking
# Default: not set
-# CMAKE_BUILD_TYPE - Type of build (release, debug)
-# Default: Release
# CMAKE_VERBOSE - Verbose build
# Default: not set
# CMAKE_SOURCE_PATH - Path to sourcedir for cmake
@@ -47,12 +45,11 @@ CMAKE_ARGS+= -DCMAKE_C_COMPILER:STRING="${CC}" \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
-DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
-DCMAKE_INSTALL_PREFIX:PATH="${CMAKE_INSTALL_PREFIX}" \
- -DCMAKE_BUILD_TYPE:STRING="${CMAKE_BUILD_TYPE}"
+ -DCMAKE_BUILD_TYPE:STRING=""
#
# Default build type and sourcedir
#
-CMAKE_BUILD_TYPE?= Release
CMAKE_SOURCE_PATH?= .
CMAKE_INSTALL_PREFIX?= ${PREFIX}
@@ -69,10 +66,10 @@ CMAKE_ARGS+= -DCMAKE_THREAD_LIBS:STRING="${PTHREAD_LIBS}" \
.endif
#
-# Force DEBUG buildtype if needed
+# Strip binaries
#
-.if defined(CMAKE_DEBUG) || defined(WITH_DEBUG)
-CMAKE_BUILD_TYPE=DEBUG
+.if !defined(WITH_DEBUG)
+CMAKE_ARGS+= -DCMAKE_INSTALL_DO_STRIP:BOOL=ON
.endif
#
@@ -87,6 +84,6 @@ CMAKE_ARGS+= -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
#
.if !target(do-configure)
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CMAKE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ${CMAKE_SOURCE_PATH}
+ @cd ${CONFIGURE_WRKSRC}; ${SETENV} ${CMAKE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ${CMAKE_SOURCE_PATH}
.endif