aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.fpc.mk
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2015-08-09 08:06:43 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2015-08-09 08:06:43 +0000
commit230cf6828ff8e331d6ad8fe0f281d3656e7592bf (patch)
treedcd9771851d8a5b000509363eeaba5add2d5d4de /Mk/bsd.fpc.mk
parent3986cfea667e50f96de500e756073fe4208720fd (diff)
downloadports-230cf6828ff8e331d6ad8fe0f281d3656e7592bf.tar.gz
ports-230cf6828ff8e331d6ad8fe0f281d3656e7592bf.zip
Notes
Diffstat (limited to 'Mk/bsd.fpc.mk')
-rw-r--r--Mk/bsd.fpc.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/bsd.fpc.mk b/Mk/bsd.fpc.mk
index be66a523890b..150df0b7395d 100644
--- a/Mk/bsd.fpc.mk
+++ b/Mk/bsd.fpc.mk
@@ -13,6 +13,9 @@
# free pascal compiler, if you need install additional fpc
# units, they can be listed there (USE_FPC= gtk x11 opengl).
#
+# USE_FPC_RUN - If you set this to "yes", free pascal units will be
+# registered also as run dependencies.
+#
# WANT_FPC_BASE - If you set this to "yes", this automatically will install
# all base units of fpc (gdbint graph ibase libasync hash
# httpd mysql netdb odbc oracle pasjpeg paszlib pthreads
@@ -197,10 +200,14 @@ zlib_UNIT= devel/fpc-zlib
. if ${_FPC_ALL_UNITS:M${UNITS}}!=""
. if ${_FPC_CFG_UNITS:M${UNITS}}!=""
BUILD_DEPENDS+= ${UNITSDIR}/${UNITS}/fpunits.cfg:${PORTSDIR}/${${UNITS:S/-/_/}_UNIT}
+. if defined(USE_FPC_RUN)
RUN_DEPENDS+= ${UNITSDIR}/${UNITS}/fpunits.cfg:${PORTSDIR}/${${UNITS:S/-/_/}_UNIT}
+. endif
. else
BUILD_DEPENDS+= ${UNITSDIR}/${UNITS}/Package.fpc:${PORTSDIR}/${${UNITS:S/-/_/}_UNIT}
+. if defined(USE_FPC_RUN)
RUN_DEPENDS+= ${UNITSDIR}/${UNITS}/Package.fpc:${PORTSDIR}/${${UNITS:S/-/_/}_UNIT}
+. endif
. endif
security-check: fpc-check-install