aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2013-10-13 21:23:35 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2013-10-13 21:23:35 +0000
commit2a0337bd2e0bd26398db46d30ecc8141319f5185 (patch)
tree548774f41a2ce2dc3e9eb1bbcab17321a91b007d /Mk/bsd.gcc.mk
parenta9bdcb49549064a6904e0eaadbae827a94810c3f (diff)
downloadports-2a0337bd2e0bd26398db46d30ecc8141319f5185.tar.gz
ports-2a0337bd2e0bd26398db46d30ecc8141319f5185.zip
Add support for USE_GCC=4.9 and USE_GCC=4.9+.
Beware, this version of GCC is _not_ anywhere near ready for production use. Use at your own risk, and rather don't use it for regular ports. Submitted by: devzone.my@gmail.com
Notes
Notes: svn path=/head/; revision=330254
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 5ef0197089a4..c40ec93e953d 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -42,7 +42,7 @@ GCC_Include_MAINTAINER= gerald@FreeBSD.org
# All GCC versions supported by the ports framework. Keep them in
# ascending order and in sync with the table below.
-GCCVERSIONS= 030402 040200 040400 040600 040700 040800
+GCCVERSIONS= 030402 040200 040400 040600 040700 040800 040900
# The first field if the OSVERSION in which it appeared in the base.
# The second field is the OSVERSION in which it disappeared from the base.
@@ -53,6 +53,7 @@ GCCVERSION_040400= 0 0 4.4
GCCVERSION_040600= 0 0 4.6
GCCVERSION_040700= 0 0 4.7
GCCVERSION_040800= 0 0 4.8
+GCCVERSION_040900= 0 0 4.9
GCC_DEFAULT_VERSION= 4.6
GCC_DEFAULT_V= ${GCC_DEFAULT_VERSION:S/.//}