aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2011-02-01 01:41:19 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2011-02-01 01:41:19 +0000
commit53b59d25b971656f934b2538870d6eb5a7cc13c9 (patch)
tree37dcd21ce49aa5db7e4f4e682b3a672b82af9d84 /Mk/bsd.gcc.mk
parent4b7c4dd1fda93b15bf54589b0d09d117c64b1f24 (diff)
Notes
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 4f73d7959309..9e523b30b8b5 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -201,6 +201,11 @@ LDFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS}
BUILD_DEPENDS+= ${_GCC_PORT_DEPENDS}:${PORTSDIR}/lang/${_GCC_BUILD_DEPENDS}
. if ${_USE_GCC} != 3.4
RUN_DEPENDS+= ${_GCC_PORT_DEPENDS}:${PORTSDIR}/lang/${_GCC_BUILD_DEPENDS}
+. if ${_USE_GCC} != 4.2
+# Later GCC ports already depend on binutils; make sure whatever we
+# build leverages this as well.
+USE_BINUTILS= yes
+. endif
. endif
.endif
.endif # defined(_USE_GCC)