aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-06-03 01:42:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-06-03 01:42:54 +0000
commitb86571032d3eb3be7b965d065d3f9273e665eb5e (patch)
tree8ce9c18a58c15ee9efb9167060de0f0ac0daa6e8 /Mk/bsd.gcc.mk
parent588b0c39a5e62b5263c2ac7409b422a2eada85f9 (diff)
downloadports-b86571032d3eb3be7b965d065d3f9273e665eb5e.tar.gz
ports-b86571032d3eb3be7b965d065d3f9273e665eb5e.zip
Notes
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk15
1 files changed, 12 insertions, 3 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index be1a97ee9205..466ead9c0df3 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -99,14 +99,23 @@ BROKEN= "Couldn't find your current GCCVERSION (OSVERSION=${OSVERSION})"
#
# If the GCC package defined in USE_GCC does not exist, but a later
# version is allowed (for example 3.1+), see if there is a later.
-# The first available version will be used.
+# First check if the base installed version is good enough, otherwise
+# get the first available version.
#
.if defined(_GCC_ORLATER)
. for v in ${GCCVERSIONS}
. if ${_USE_GCC} == ${_GCCVERSION_${v}_V}
-_GCC_MIN:= true
+_GCC_MIN1:= true
. endif
-. if defined(_GCC_MIN) && defined(_GCC_FOUND${v}) && !defined(_GCC_FOUND)
+. if defined(_GCC_MIN1) && defined(_GCC_FOUND${v}) && ${_GCC_FOUND${v}}=="base" && !defined(_GCC_FOUND)
+_GCC_FOUND:= ${_GCCVERSION_${v}_V}
+. endif
+. endfor
+. for v in ${GCCVERSIONS}
+. if ${_USE_GCC} == ${_GCCVERSION_${v}_V}
+_GCC_MIN2:= true
+. endif
+. if defined(_GCC_MIN2) && defined(_GCC_FOUND${v}) && !defined(_GCC_FOUND)
_GCC_FOUND:= ${_GCCVERSION_${v}_V}
. endif
. endfor