aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-08-26 06:38:32 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-08-26 06:38:32 +0000
commitfd9ddf4a36fd0ab126d6c6d0948b99d335e84a31 (patch)
tree2326c0dcbe308c1ec8225b5c5da94be764aa4e34 /Mk/bsd.gecko.mk
parente38f12c62c8796270f62a2482c9480f8bc657e2a (diff)
downloadports-fd9ddf4a36fd0ab126d6c6d0948b99d335e84a31.tar.gz
ports-fd9ddf4a36fd0ab126d6c6d0948b99d335e84a31.zip
Notes
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index e1faba3c4ef3..50737b32ecf2 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -142,7 +142,14 @@ MOZ_OPTIONS+= --enable-jemalloc
.endif # !DragonFly
# Standard depends
-_ALL_DEPENDS= cairo event ffi graphite harfbuzz hunspell icu jpeg nspr nss opus png pixman soundtouch sqlite vorbis vpx
+_ALL_DEPENDS= cairo event ffi graphite harfbuzz hunspell icu jpeg nspr nss opus png pixman soundtouch sqlite vpx
+
+.if ${PORT_OPTIONS:MINTEGER_SAMPLES}
+MOZ_EXPORT+= MOZ_INTEGER_SAMPLES=1
+_ALL_DEPENDS+= tremor
+.else
+_ALL_DEPENDS+= vorbis
+.endif
.if ! ${PORT_OPTIONS:MBUNDLED_CAIRO}
cairo_LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo
@@ -209,6 +216,9 @@ sqlite_MOZ_OPTIONS= --enable-system-sqlite
theora_LIB_DEPENDS= libtheora.so:${PORTSDIR}/multimedia/libtheora
theora_MOZ_OPTIONS= --with-system-theora
+tremor_LIB_DEPENDS= libvorbisidec.so:${PORTSDIR}/audio/libtremor
+tremor_MOZ_OPTIONS= --with-system-tremor --with-system-ogg
+
vorbis_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
vorbis_MOZ_OPTIONS= --with-system-vorbis --with-system-ogg
.endif