aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2012-05-12 16:23:10 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2012-05-12 16:23:10 +0000
commita251f7548a0ed503548e4609ea5145368efa466b (patch)
treed8aaf43c95b91508eab4f779fc05c50bd4296785 /Mk/bsd.gecko.mk
parent7cdb8ac0483989a5196e15da320351f028e117e3 (diff)
downloadports-a251f7548a0ed503548e4609ea5145368efa466b.tar.gz
ports-a251f7548a0ed503548e4609ea5145368efa466b.zip
Notes
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk44
1 files changed, 8 insertions, 36 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index faf7cd8f0838..051eebeb3006 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -181,7 +181,7 @@ Gecko_Pre_Include= bsd.gecko.mk
# is given by the maintainer via the port or by the
# user via defined variable try to find the highest
# stable installed version.
-# Available values: yes 10+ 12+ 36+ 10 12+ 36
+# Available values: yes 10+ 12+ 10 12+
# NOTE:
# default value 10 is used in case of USE_FIREFOX=yes
#
@@ -203,7 +203,7 @@ Gecko_Pre_Include= bsd.gecko.mk
# version is given by the maintainer via the port
# or by the user via defined variable try to find
# the highest stable installed version.
-# Available values: yes 10+ 12+ 31+ 10 12 31
+# Available values: yes 10+ 12+ 10 12
# NOTE:
# default value 10 is used in case of USE_THUNDERBIRD=yes
#
@@ -223,11 +223,10 @@ _FIREFOX_BUILD_DEPENDS= yes
.endif
_FIREFOX_DEFAULT_VERSION= 10
-_FIREFOX_VERSIONS= 10 12 36
-_FIREFOX_RANGE_VERSIONS= 10+ 12+ 36+
+_FIREFOX_VERSIONS= 10 12
+_FIREFOX_RANGE_VERSIONS= 10+ 12+
-# For specifying [36, ..]+
-_FIREFOX_36P= 36 ${_FIREFOX_12P}
+# For specifying [10, ..]+
_FIREFOX_12P= 12 ${_FIREFOX_10P}
_FIREFOX_10P= 10
@@ -269,16 +268,8 @@ _SUPFIREFOX= yes
.endif
.endif
.if ${_SUPFIREFOX} == no
-.if ${_FIREFOX_VER} < 36
_DISPLAY_VERSION_HAVE= ${_FIREFOX_VER}
-.else
-_DISPLAY_VERSION_HAVE:= ${_FIREFOX_VER:C/([0-9])([0-9])/\1.\2/}
-.endif
-.if ${USE_FIREFOX} < 36
_DISPLAY_VERSION_WANT= ${USE_FIREFOX}
-.else
-_DISPLAY_VERSION_WANT:= ${USE_FIREFOX:C/([0-9])([0-9])/\1.\2/}
-.endif
IGNORE= cannot install: Firefox versions mismatch: firefox-${_DISPLAY_VERSION_HAVE} is installed and wanted version is firefox-${_DISPLAY_VERSION_WANT}
.endif
@@ -291,7 +282,6 @@ IGNORE= cannot install: unknown Firefox version: firefox-${USE_FIREFOX:C/([0-9
# Dependence lines for different Firefox versions
10_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
12_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
-36_DEPENDS= ${LOCALBASE}/lib/firefox3/firefox:${PORTSDIR}/www/firefox36
# Add dependencies
.if defined(USE_FIREFOX)
@@ -383,11 +373,10 @@ _THUNDERBIRD_BUILD_DEPENDS= yes
.endif
_THUNDERBIRD_DEFAULT_VERSION= 10
-_THUNDERBIRD_VERSIONS= 10 12 31
-_THUNDERBIRD_RANGE_VERSIONS= 10+ 12+ 31+
+_THUNDERBIRD_VERSIONS= 10 12
+_THUNDERBIRD_RANGE_VERSIONS= 10+ 12+
-# For specifying [31, 30, ..]+
-_THUNDERBIRD_31P= 31 ${_THUNDERBIRD_12P}
+# For specifying [10, ..]+
_THUNDERBIRD_12P= 12 ${_THUNDERBIRD_10P}
_THUNDERBIRD_10P= 10
@@ -397,16 +386,8 @@ USE_THUNDERBIRD= ${_THUNDERBIRD_DEFAULT_VERSION}
.endif
# Setting/finding Thunderbird version we want.
-.if exists(${LOCALBASE}/bin/thunderbird)
_TMP_VER!= ${LOCALBASE}/bin/thunderbird --version 2>/dev/null | ${HEAD} -1 | ${SED} -e 's/ Thunderbird \([0-9]\{1,2\}\)\.\([0-9]*\).*/\1\2/'
-.if ${_TMP_VER} >= 100
_THUNDERBIRD_VER:= ${_TMP_VER:C/([0-9][0-9]).*/\1/}
-.else
-_THUNDERBIRD_VER= ${_TMP_VER}
-.endif
-.elif exists(${LOCALBASE}/bin/thunderbird3)
-_THUNDERBIRD_VER!= ${LOCALBASE}/bin/thunderbird3 --version 2>/dev/null | ${HEAD} -1 | ${SED} -e 's/ Thunderbird \([0-9]\)\.\([0-9]*\).*/\1\2/'
-.endif
# Check if installed Thunderbird version matches the wanted one
.if defined(_THUNDERBIRD_VER)
@@ -429,16 +410,8 @@ _SUPTHUNDERBIRD= yes
.endif
.endif
.if ${_SUPTHUNDERBIRD} != yes
-.if ${_THUNDERBIRD_VER} < 31
_DISPLAY_VERSION_HAVE= ${_THUNDERBIRD_VER}
-.else
-_DISPLAY_VERSION_HAVE:= ${_THUNDERBIRD_VER:C/([0-9])([0-9])/\1.\2/}
-.endif
-.if ${USE_THUNDERBIRD} < 31
_DISPLAY_VERSION_WANT= ${USE_THUNDERBIRD}
-.else
-_DISPLAY_VERSION_WANT:= ${USE_THUNDERBIRD:C/([0-9])([0-9])/\1.\2/}
-.endif
IGNORE= cannot install: Thunderbird versions mismatch: thunderbird-${_DISPLAY_VERSION_HAVE} is installed and wanted version is thunderbird-${_DISPLAY_VERSION_WANT}
.endif
.endif
@@ -450,7 +423,6 @@ IGNORE= cannot install: unknown Thunderbird version: thunderbird-${USE_THUNDER
# Dependence lines for different Thunderbird versions
10_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird-esr
12_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird
-31_DEPENDS= ${LOCALBASE}/lib/thunderbird3/thunderbird:${PORTSDIR}/mail/thunderbird3
# Add dependencies
.if defined(USE_THUNDERBIRD)