aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-01-10 22:29:23 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-01-10 22:29:23 +0000
commite676e2910f592704af67424758ebd4cfdff9ebcd (patch)
treedd14b47bf2d53036668a1976cb68d74952705242 /Mk/bsd.gecko.mk
parentb3cd07ff84dd89a740098e7c418cdb52825e1d18 (diff)
downloadports-e676e2910f592704af67424758ebd4cfdff9ebcd.tar.gz
ports-e676e2910f592704af67424758ebd4cfdff9ebcd.zip
Notes
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk38
1 files changed, 19 insertions, 19 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 46e59a7ebd49..43f82953ef2d 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -179,9 +179,9 @@ Gecko_Pre_Include= bsd.gecko.mk
# is given by the maintainer via the port or by the
# user via defined variable try to find the highest
# stable installed version.
-# Available values: yes 10+ 17+ 10 17+
+# Available values: yes 17+ 18+ 17 18+
# NOTE:
-# default value 10 is used in case of USE_FIREFOX=yes
+# default value 17 is used in case of USE_FIREFOX=yes
#
# USE_FIREFOX_BUILD Add buildtime dependency on Firefox.
# Available values: see USE_FIREFOX
@@ -190,9 +190,9 @@ Gecko_Pre_Include= bsd.gecko.mk
# version is given by the maintainer via the port
# or by the user via defined variable try to find
# the highest stable installed version.
-# Available values: yes 14+ 14
+# Available values: yes 15+ 15
# NOTE:
-# default value 14 is used in case of USE_SEAMONKEY=yes
+# default value 15 is used in case of USE_SEAMONKEY=yes
#
# USE_SEAMONKEY_BUILD Add buildtime dependency on SeaMonkey.
# Available values: see USE_SEAMONKEY
@@ -203,7 +203,7 @@ Gecko_Pre_Include= bsd.gecko.mk
# the highest stable installed version.
# Available values: yes 10+ 17+ 10 17
# NOTE:
-# default value 10 is used in case of USE_THUNDERBIRD=yes
+# default value 17 is used in case of USE_THUNDERBIRD=yes
#
# USE_THUNDERBIRD_BUILD Add buildtime dependency on Thunderbird.
# Available values: see USE_THUNDERBIRD
@@ -220,13 +220,13 @@ USE_FIREFOX:= ${USE_FIREFOX_BUILD}
_FIREFOX_BUILD_DEPENDS= yes
.endif
-_FIREFOX_DEFAULT_VERSION= 10
-_FIREFOX_VERSIONS= 10 17
-_FIREFOX_RANGE_VERSIONS= 10+ 17+
+_FIREFOX_DEFAULT_VERSION= 17
+_FIREFOX_VERSIONS= 17 18
+_FIREFOX_RANGE_VERSIONS= 17+ 18+
-# For specifying [10, ..]+
-_FIREFOX_17P= 17 ${_FIREFOX_10P}
-_FIREFOX_10P= 10
+# For specifying [17, ..]+
+_FIREFOX_18P= 18 ${_FIREFOX_17P}
+_FIREFOX_17P= 17
# Set the default Firefox version and check if USE_FIREFOX=yes was given
.if ${USE_FIREFOX} == "yes"
@@ -271,8 +271,8 @@ IGNORE= cannot install: unknown Firefox version: firefox-${USE_FIREFOX:C/([0-9
.endif
# Dependence lines for different Firefox versions
-10_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
-17_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
+17_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
+18_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
# Add dependencies
.if defined(USE_FIREFOX)
@@ -294,12 +294,12 @@ USE_SEAMONKEY:= ${USE_SEAMONKEY_BUILD}
_SEAMONKEY_BUILD_DEPENDS= yes
.endif
-_SEAMONKEY_DEFAULT_VERSION= 14
-_SEAMONKEY_VERSIONS= 14
-_SEAMONKEY_RANGE_VERSIONS= 14+
+_SEAMONKEY_DEFAULT_VERSION= 15
+_SEAMONKEY_VERSIONS= 15
+_SEAMONKEY_RANGE_VERSIONS= 15+
-# For specifying [14, ..]+
-_SEAMONKEY_14P= 14
+# For specifying [15, ..]+
+_SEAMONKEY_15P= 15
# Set the default SeaMonkey version and check if USE_SEAMONKEY=yes was given
.if ${USE_SEAMONKEY} == "yes"
@@ -341,7 +341,7 @@ IGNORE= cannot install: unknown SeaMonkey version: seamonkey-2.${USE_SEAMONKEY
.endif
# Dependence lines for different SeaMonkey versions
-14_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey:${PORTSDIR}/www/seamonkey
+15_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey:${PORTSDIR}/www/seamonkey
# Add dependencies
.if defined(USE_SEAMONKEY)