aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-01-21 23:03:45 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-01-21 23:03:45 +0000
commit94ba0152445e65e1e80c5c62d4b11c594cfe0158 (patch)
tree957bfc095bd19d6545720169937ab78ee8fb4d0c /Mk/bsd.gecko.mk
parent0c02d51ac9bd9121a3cf11ec9a4134a31bff6ab4 (diff)
downloadports-94ba0152445e65e1e80c5c62d4b11c594cfe0158.tar.gz
ports-94ba0152445e65e1e80c5c62d4b11c594cfe0158.zip
Notes
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 354568fc6dd4..2c91d810fb1f 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -152,7 +152,7 @@ RUSTFLAGS+= ${CFLAGS:M-mcpu=*:S/-mcpu=/-C target-cpu=/}
.endif
# Standard depends
-_ALL_DEPENDS= event ffi graphite harfbuzz hunspell icu jpeg nspr nss png pixman sqlite vpx
+_ALL_DEPENDS= event ffi graphite harfbuzz hunspell icu jpeg nspr nss png pixman sqlite vpx webp
event_LIB_DEPENDS= libevent.so:devel/libevent
event_MOZ_OPTIONS= --with-system-libevent
@@ -197,6 +197,9 @@ sqlite_MOZ_OPTIONS= --enable-system-sqlite
vpx_LIB_DEPENDS= libvpx.so:multimedia/libvpx
vpx_MOZ_OPTIONS= --with-system-libvpx
+webp_LIB_DEPENDS= libwebp.so:graphics/webp
+webp_MOZ_OPTIONS= --with-system-webp
+
.for use in ${USE_MOZILLA}
${use:S/-/_WITHOUT_/}= ${TRUE}
.endfor
@@ -339,7 +342,7 @@ post-patch-SNDIO-on:
.endif
.if ${PORT_OPTIONS:MRUST} || ${MOZILLA_VER:R:R} >= 54
-BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.29:lang/${RUST_DEFAULT}
+BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.30:lang/${RUST_DEFAULT}
. if ${MOZILLA_VER:R:R} < 54
MOZ_OPTIONS+= --enable-rust
. endif